Opened 7 years ago

Last modified 6 years ago

#8491 reopened Bug report

Use the server's external IP address instead not working

Reported by: EDV Owned by:
Priority: normal Component: FileZilla Client
Keywords: external IP address Cc:
Component version: Operating system type: Windows
Operating system version: Win7x64SP1

Description

we have following issue

protocol: ftp
encryption: Require explicit FTP over TLS
Logon: normal
our client have an internal ip 10.35..4
the destination address is the internal ip address from our firewall : 10.35..254
the real destination is an server outside: 172......

when the client open the connection to the ftp server:
The ftp connection can be opened to the destination server!

But wenn the command "LIST" where send to the server, we don't get a sign from the real destination ftp server, because the protocol package has the wrong IP address information included into the package to the client. Maybe it wll be a bug?

when we use another software 4 example "smartftp", to do the same thing -> it works fine.
We we want to use flezilla.

Attachments (2)

Unbenannt.jpg (215.2 KB) - added by EDV 7 years ago.
Pictur of Infos
issue_explaination2.pdf (165.1 KB) - added by EDV 6 years ago.
Picture With Issue Explaination

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by EDV

Attachment: Unbenannt.jpg added

Pictur of Infos

comment:1 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

Please be sure to understand the differences between active and passive mode. Maybe you should use active mode FTP instead? Does that help?

comment:2 Changed 6 years ago by Alexander Schuch

Resolution: outdated
Status: moreinfoclosed

No reply for more than 28 days.

comment:3 Changed 6 years ago by cochran

Resolution: outdated
Status: closedreopened

Hello,

we have the same issue.

We must use a internal IP (on a firewall) with NATing to the destination IP.

Only passive mode is in this case possible.

The problem is, that in the FTP-packet (or in our case a FTPS-packet) is the outside IP is transmitted. FileZilla must ignore this and use a customized ip (the locally IP of the Firewall).

That is that, what the other FTP-clients do to fix this FTP issue.

In the best case this option is placed in the connection settings. In the moment are only the global option avaiable and works not.

comment:4 Changed 6 years ago by Alexander Schuch

Status: reopenedmoreinfo_reopened

I do not fully understand.

You connect to a server. You use PASV command. The server replies with an IP address and port. But you do not want to use that IP address and port but another one?

Changed 6 years ago by EDV

Attachment: issue_explaination2.pdf added

Picture With Issue Explaination

comment:5 Changed 6 years ago by EDV

Status: moreinfo_reopenedreopened

Hello Team.

I attached a file with a short explaination inside.

We hope it works!

Note: See TracTickets for help on using tickets.