Opened 7 years ago

Closed 6 years ago

#8327 closed Feature request (duplicate)

Copy file link as http

Reported by: Mitch Owned by:
Priority: normal Component: FileZilla Client
Keywords: Copy as http, Link Cc:
Component version: Operating system type: Windows
Operating system version: Win7 x64

Description

It would be very convenient to have the capability to use the context menu to copy URL(s) as web links in addition to ftp.

IE, in the current implementation, copying a URL with the rmb menu might yield:
ftp://MitchR@thepixelfarm.com/tmp/fc_expressionFolderIssue.png

but often, what I need is:
http://www.thepixelfarm.com/tmp/fc_expressionFolderIssue.png

Thanks.

Change History (4)

comment:1 Changed 7 years ago by Alexander Schuch

This idea has been proposed in #2591 already, but it only is partly implemented:

"Example: I'm connected to http://example.org via ftp://example.org . Filezilla lists in the directory /store the file log.txt . I would Filezilla with a right click item should copy to clipboard the URL http://example.org/store/log.txt. It can be done putting in Site Manager the value "Domain URL"."

comment:2 Changed 7 years ago by Mitch

Thanks for the reply.
Where in the SiteManager do I add "Domain URL"?

comment:3 Changed 7 years ago by Alexander Schuch

It is not yet implemented. It is an idea/a proposal of where it could be implemented in a later version.

comment:4 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #4826.

Note: See TracTickets for help on using tickets.