Opened 8 years ago

Closed 6 years ago

#8165 closed Bug report (outdated)

Refresh not working

Reported by: linette Owned by: rajesh kumar
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Operating system: Name: Windows NT 6.1 (build 7600) Version: 6.1 Platform: 64 bit system

Description

I've updated a local file and even after hitting f5, right click and 'refresh' and closing and reopening filezilla, it's caching the old version of the file. I've checked in file explorer and it's seeing the new version, but filezilla is trapped in the past!

The only way I can upload my new file is to save it in a different location on my harddrive and then upload it.

version: 3.5.3

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2012-01-08
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Change History (10)

comment:1 by Alexander Schuch, 8 years ago

Status: newmoreinfo

Can you reproduce the problem?
How did you actually update the file?
Is is a "real" local file or a file on a network drive?
If you use the command line interface (cmd.exe) and issue "dir" command in the direction in question, do you get what you see in FileZilla or what you see in Explorer?

comment:2 by linette, 8 years ago

Status: moreinfonew

I can reproduce the problem, even after full system restart.

From my test, oddly it seems to affect .html files, but not a .css file that I tried the same procedure on?!? (filetype? length of extention? this seems weird!)

So, I open the file in text pad. I alter a part of it and hit save. At this point I check the modified time in explorer and via cmd line. Both have updated. Hitting refresh in Filezilla the information hasn't changed. If I try to then copy the file across to the remote location it quotes the pre-save modify time.

This is a local directory (although it is synced with dropbox) - the DIR command shows the modified time I would expect.

I have a pdf of screenshots of the error here: (too large to attach here at 500k)
https://dl.dropbox.com/u/1996889/filezillaerror.pdf

comment:3 by linette, 8 years ago

Actually strike what I said about .css working, as that isn't today. Maybe it was a function of being the first file from the first time I opened filezilla? Who knows?

comment:4 by rajesh kumar, 8 years ago

Cc: mailto.rajesh05@… added
Owner: set to rajesh kumar
Status: newaccepted

comment:5 by Alexander Schuch, 8 years ago

Status: acceptedmoreinfo_accepted

I am a bit confused. Does it work now?

And just to summarise: You open FileZilla and navigate to a local Dropbox directory so that you see the local filelist in FileZilla. You then edit a file in your local Dropbox directory. After editing the file, the new modification date is properly shown in Explorer and on command line (dir). But refreshing the local directory list in FileZilla does not show the new modification date?

Is that correct?

And: Do you have this problem in other local directories OUTSIDE your Dropbox directory as well? Maybe it is related to Dropbox?

comment:6 by linette, 8 years ago

Status: moreinfo_acceptedaccepted

Your summary is completely correct, and it is still not working. With more testing, I find even if I add a new file to that directory (visible with dir and explorer), filezilla cannot see it, even after hitting refresh.

I think dropbox is a factor in this, as further tests have shown other directories to work as expected. So the question is, what is it about a dropbox folder that means filezilla can't see what the OS does?

comment:7 by rajesh kumar, 8 years ago

Status: acceptedmoreinfo_accepted

comment:8 by rajesh kumar, 8 years ago

Cc: mailto.rajesh05@… removed
Status: moreinfo_acceptedaccepted

comment:9 by Bruno Ramos, 6 years ago

Status: acceptedmoreinfo_accepted

Huge number of changes since ticket was created.

Could you please confirm if this is still happening with the latest version?

comment:10 by Alexander Schuch, 6 years ago

Resolution: outdated
Status: moreinfo_acceptedclosed

No reply for more than 28 days.

Note: See TracTickets for help on using tickets.