Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#8141 closed Patch (fixed)

bag - Hebrew is shown reverse

Reported by: orel Owned by:
Priority: normal Component: FileZilla Client
Keywords: Hebrew is shown reverse Cc:
Component version: Operating system type: Windows
Operating system version: windows 7

Description

Hebrew is shown reverse

Hebrew is the opposite of increases in the down line

See photo

Attachments (3)

bag.png (141.6 KB) - added by orel 7 years ago.
bag1.png (192.0 KB) - added by orel 7 years ago.
8141_mirrored_characters.patch (553 bytes) - added by David 7 years ago.
8141_mirrored_characters.patch

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by orel

Attachment: bag.png added

comment:1 Changed 7 years ago by David

Can you please elaborate on the expected behaviour.
I can see that numbers are mirrored but is the order correct?
It would help if you could create an example with the same text as in the picture.

Changed 7 years ago by orel

Attachment: bag1.png added

comment:2 Changed 7 years ago by orel

No, the letters not in the correct order, and they are reflected in the addition ..

look bag1.png

comment:3 Changed 7 years ago by Alexander Schuch

This bug has been reported already in #5621. However, the screenshot here is more detailed, so I marked the other bug as a duplicate. (Another screenshot is present there.)

comment:4 Changed 7 years ago by Alexander Schuch

Priority: criticalnormal

Changed 7 years ago by David

8141_mirrored_characters.patch

comment:5 Changed 7 years ago by David

The problem was due to different layout directions on background drawing DC and the actual DC shown. Perhaps it could be argued that this is something which should be changed within wxWidgets but I have not dug that deep.

Attached is a patch for review.

As a side-note I noticed that wxMemoryDC::IsOk isn't called after object creation.

comment:6 Changed 7 years ago by Tim Kosse

Type: Bug reportPatch

comment:7 Changed 7 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Using FileZilla mirrored makes me dizzy. :)

Thanks for the patch, committed.

Note: See TracTickets for help on using tickets.