Opened 7 years ago

Closed 5 years ago

#8136 closed Bug report (worksforme)

FTPS with PASV not working from internet side.

Reported by: Steven Owned by:
Priority: normal Component: FileZilla Server
Keywords: FTPS PASV internet external Cc: vhsteven@…
Component version: Operating system type: Windows
Operating system version: Win7 32bit

Description

I've set up my server to enable implicit FTPS (port 990) but the unsecure connection method is still accepted too.

When I try to connect to the server using unencrypted method, everything works fine, no matter if I'm local or internet originated.
But for FTPS, it's different. From local network, everything is fine, from the internet side the connection goes as far as switching to passive (PASV) mode. From there on, connection hangs.
I checked the logs on my client and believe to know the cause (but not the solution): Upon switching to PASV mode, my client is given the local IP-address instead of the real 'outside' ip-address.
It is as if the server suddenly believes this connection to be on the local net and thus not send the 'real' address.

I.o.w. when using FTPS and PASV mode enabled for all but local connections, Filezilla server is still sending the local ip-address together with the port nr to use for the passive connection to an external client trying to connect.
This isn't so for unsecure connections and therefore I believe this to be a bug.

Attachments (1)

FTP client log.txt (586 bytes) - added by Steven 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Steven

Attachment: FTP client log.txt added

comment:1 Changed 5 years ago by Tim Kosse

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.