Opened 7 years ago

Closed 3 years ago

#8108 closed Bug report (duplicate)

Unintentional drag without holding down mouse button

Reported by: Timberline Owned by:
Priority: normal Component: FileZilla Client
Keywords: drag Cc:
Component version: Operating system type: Windows
Operating system version: XP SP3

Description (last modified by Tim Kosse)

On three occasions now I have gotten into a supposed drag state in the server tab with no intention and no cue (that I noticed) that I was in that state. The first time a whole document root and thus its site "disappeared" for a while. After finding it, I assumed I must indeed have dragged it into the adjacent folder in haste with a sloppy-slidy click or double-click, because I was rushing half an hour before a big demo.

But now I see it is possible somehow to unknowingly initiate a drag state (by sloppy click?), then scroll around for a while (many seconds) with no mouse button held, then click on a folder and Filezilla "drops" or attempts to drop the folder it thought you were dragging. At least in the server tab. I'm reluctant to experiment too much with trying to duplicate this.

I haven't been experiencing this in any other application.

It's dangerous enough that I looked all around for an option to disable dragging of files or folders in Filezilla but apparently it can't be disabled.

I really like FZ but now I'm very nervous I'll damage a site again without noticing. This third time, the only reason it didn't happen was because the folder I clicked was a subfolder of -- again -- the document root. A less obvious moved folder could go unnoticed.

FileZilla Client


Version: 3.5.3

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2012-01-08
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.12
GnuTLS: 2.10.4

Operating system:

Name: Windows XP (build 2600, Service Pack 3)
Version: 5.1
Platform: 32 bit system

Change History (1)

comment:1 Changed 3 years ago by Tim Kosse

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #2191

Note: See TracTickets for help on using tickets.