Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#7911 closed Bug report (wontfix)

Custom time format results in blank last modified column

Reported by: drew.woz Owned by:
Priority: normal Component: FileZilla Client
Keywords: custom time format Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7

Description

When using the custom time format %H:%M:%S%P, the resulting Last modified column is blank. However, when using custom %H:%M:%S, the correct data/time is listed, without the am/pm.

I haven't tried other custom time settings because the %P option is the only of interest to me.

Change History (8)

comment:1 Changed 7 years ago by Alexander Schuch

Status: newmoreinfo

I right now tries on Kubuntu and it works for me. So…

Which version of FileZilla are you using? Can you please provide logs?

"If possible, provide the contents from the message log. To do so, you should set the program's language to English, set the debug level to 3 in the settings and restart the client. Then connect to the server, perform the action that causes problems and copy the entire log to the clipboard and attach it to the bug report.
Do not tamper with the log, leave it exactly as is. Do not obfuscate any addresses or filenames. You will most certainly remove vital information from the log if you modify it."

Please make sure "raw directory listings" are enabled.

comment:2 Changed 7 years ago by Alexander Schuch

Resolution: worksforme
Status: moreinfoclosed

I tried it on ftp.kernel.org using FileZilla 3.5.3 on Kubuntu 12.04 - works for me.

comment:3 Changed 7 years ago by drew.woz

Resolution: worksforme
Status: closedreopened

Hey Guys, thanks for investigating.

I also confirmed that on Ubuntu 12.04, the 'custom' date/time appears as desired. However, please note the original bug report says 'windows'. I just tried it on windows 7 and the bug remains as a 'blank' date/time field.

comment:4 Changed 7 years ago by Alexander Schuch

Status: reopenedmoreinfo_reopened

You tried the very same server on Unix and on Windows? This is just to make sure the FTP server actually sends the same timestamp (with hour and minute resolution).

comment:5 Changed 7 years ago by drew.woz

Status: moreinfo_reopenedreopened

I did not try the 'server' on either platform.

The suspect component is "FileZilla Client" as noted in the bug report. One does not have to connect to a server to observe the problem. Just look at local file folder, set the custom date/time format, refresh the local file listing.

comment:6 Changed 7 years ago by Alexander Schuch

Resolution: wontfix
Status: reopenedclosed

Thanks for your hint about the local file list.

The modifier %P does not work on Windows - it is a GNU extension. On Windows you can use %p which does almost the same.

comment:8 Changed 6 years ago by drew.woz

The %p workaround is a reasonable solution. Thanks for investigating.

comment:10 Changed 6 years ago by drew.woz

masjeck,

Virus scanner is not the source of this problem - I disabled virus scanner and problem persists. I believe that "ci-dev" has identified this bug to be a windows/gnu issue that will not be fixed. It is closed.

Note: See TracTickets for help on using tickets.