Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#7837 closed Bug report (fixed)

Problem Uploading via FTPS.

Reported by: Ben Timby Owned by:
Priority: blocker Component: FileZilla Client
Keywords: Cc: netscout, arthur@…, leho@…, eko-priv@…, ap@…
Component version: Operating system type: Linux
Operating system version: Fedora 16 and Gentoo

Description

I recently installed Fedora 16 onto my laptop. Since then I have been having trouble uploading over FTPS. This affects both FTPS and FTPES modes, and only affects uploads.

What happens is that the upload proceeds for only a few Kilobytes, then the connection times out and the upload resumes (REST). For another few Kilobytes, then times out again. Et. Cetera.

Trying an older version of FileZilla on Ubuntu works fine. However, an older version of FileZilla on Fedora still fails. My guess is that the problem might be due to the version of GnuTLS on Fedora, but this is only a guess. Below are the details of the versions of FileZilla I have tested.

Fedora (not working):

FileZilla Client


Version: 3.5.1

Build information:

Compiled for: x86_64-redhat-linux-gnu
Compiled on: x86_64-redhat-linux-gnu
Build date: 2011-08-31
Compiled with: gcc (GCC) 4.6.1 20110804 (Red Hat 4.6.1-7)
Compiler flags: -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wall -g -fexceptions -std=gnu++0x

Linked against:

wxWidgets: 2.8.12
GnuTLS: 2.12.7

Operating system:

Name: Linux 3.1.1-1.fc16.x86_64 x86_64
Version: 3.1

  • Note, I also tried version 3.3.3 on Fedora 16 with the same result.

Ubuntu (working):

FileZilla Client


Version: 3.3.5.1

Build information:

Compiled for: x86_64-pc-linux-gnu
Compiled on: x86_64-pc-linux-gnu
Build date: 2010-12-12
Compiled with: gcc (Ubuntu/Linaro 4.5.1-12ubuntu1) 4.5.2
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.11
GnuTLS: 2.8.6

Operating system:

Name: Linux 2.6.38-12-generic x86_64
Version: 2.6

I have two log files attached. ftp-log-working.txt shows the log from the Ubuntu client performing a successful upload. ftp-log-broken.txt shows the log from the Fedora client.

In the broken log, you can see the problem spot:

--
12:25:35 Response: 150 File status okay. About to open data connection.
12:25:35 Trace: CFtpControlSocket::TransferParseResponse()
12:25:35 Trace: code = 1
12:25:35 Trace: state = 4
12:25:35 Trace: CFtpControlSocket::SendNextCommand()
12:25:35 Trace: CFtpControlSocket::TransferSend()
12:25:35 Trace: state = 5
12:25:35 Trace: CTlsSocket::OnRead()
12:25:35 Trace: CTlsSocket::ContinueHandshake()
12:25:35 Trace: Handshake successful
12:25:35 Trace: Session resumed
12:25:35 Trace: Cipher: AES-256-CBC, MAC: SHA1
12:25:35 Trace: CTransferSocket::OnConnect
12:25:35 Trace: First EAGAIN in CTransferSocket::OnSend()
12:26:15 Error: Connection timed out
--

But in the working log you see:

--
07:24:55 Response: 150 File status okay. About to open data connection.
07:24:55 Trace: CFtpControlSocket::TransferParseResponse()
07:24:55 Trace: code = 1
07:24:55 Trace: state = 4
07:24:55 Trace: CFtpControlSocket::SendNextCommand()
07:24:55 Trace: CFtpControlSocket::TransferSend()
07:24:55 Trace: state = 5
07:24:55 Trace: CTlsSocket::OnRead()
07:24:55 Trace: CTlsSocket::ContinueHandshake()
07:24:55 Trace: Handshake successful
07:24:55 Trace: Session resumed
07:24:55 Trace: Cipher: AES-256-CBC, MAC: SHA1
07:24:55 Trace: CTransferSocket::OnConnect
07:24:55 Trace: First EAGAIN in CTransferSocket::OnSend()
07:24:55 Trace: CTlsSocket::OnSend()
07:24:55 Trace: Made progress in CTransferSocket::OnSend()
07:24:56 Trace: CTlsSocket::OnSend()
07:24:56 Trace: CTlsSocket::OnSend()
...
--

CTlsSockt::OnSend() continues until I cancel the transfer. I am not sure why the broken log stops after the EAGAIN error.

Please let me know if I can provide any other information that might be useful.

Attachments (4)

ftp-log-broken.txt (30.1 KB) - added by Ben Timby 8 years ago.
Log file from Fedora client.
ftp-log-working.txt (12.2 KB) - added by Ben Timby 8 years ago.
Log file from Ubuntu client.
broken-gnutls_3.0.13.txt (7.1 KB) - added by Marc Jauvin 8 years ago.
log for broken STOR cmd with Filezilla v3.5.3 (gnutls v3.0.13)
filezilla-3.6.0.log (109.5 KB) - added by Andreas Prieß 7 years ago.
Filezilla-3.6.0 with GnuTLS 3.1.4 debug log with upload failing multiple times

Download all attachments as: .zip

Change History (18)

Changed 8 years ago by Ben Timby

Attachment: ftp-log-broken.txt added

Log file from Fedora client.

Changed 8 years ago by Ben Timby

Attachment: ftp-log-working.txt added

Log file from Ubuntu client.

comment:1 Changed 8 years ago by netscout

Cc: netscout added

I can confirm that on Fedora Code 16 x86

comment:2 Changed 8 years ago by Arthur Țițeică

Priority: normalblocker

I've also seen this in Archlinux X64

FileZilla Client


Version: 3.5.3

Build information:

Compiled for: x86_64-unknown-linux-gnu
Compiled on: x86_64-unknown-linux-gnu
Build date: 2012-01-08
Compiled with: gcc (GCC) 4.6.2 20111223 (prerelease)
Compiler flags: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wall -g -fexceptions -std=gnu++0x

Linked against:

wxWidgets: 2.8.12
GnuTLS: 3.0.11

Operating system:

Name: Linux 3.2.0-2-ARCH x86_64
Version: 3.2

comment:3 Changed 8 years ago by Arthur Țițeică

Cc: arthur@… added

comment:4 Changed 8 years ago by Marc Jauvin

I have tried multiple distributions (both 32 and 64 bits), and it's working fine using GNUTLS <= 2.10.X, but when I update to GNUTLS >= 2.12.X, it breaks with the same behavior as described in this bug report.

Hope this helps resolve the problem.

comment:5 Changed 8 years ago by Marc Jauvin

I compiled the latest GNU TLS (v3.0.13) and the latest Filezilla (v3.5.3) and the problem is still present. Here is the filezilla build info (also see the debug file attached):

FileZilla Client


Version: 3.5.3

Build information:

Compiled for: x86_64-unknown-linux-gnu
Compiled on: x86_64-unknown-linux-gnu
Build date: 2012-02-20
Compiled with: gcc (Debian 4.6.2-14) 4.6.2
Compiler flags: -g -O2 -Wall -g -fexceptions -std=gnu++0x

Linked against:

wxWidgets: 2.8.12
GnuTLS: 3.0.13

Operating system:

Name: Linux 3.2.0-1-amd64 x86_64
Version: 3.2

Changed 8 years ago by Marc Jauvin

Attachment: broken-gnutls_3.0.13.txt added

log for broken STOR cmd with Filezilla v3.5.3 (gnutls v3.0.13)

comment:6 Changed 8 years ago by Marc Jauvin

I tried to narrow down at exactly what version of GNU TLS this started happening, so I compiled v2.10.5 (last release of the 2.10.X series): it's working fine.

I then compiled v2.12.0 (it actually reports as v2.11.7 once loaded in Filezilla) and this one is NOT working.

So something happened during the 2.11.X development cycle to cause this mess.

Hope this helps.

comment:7 Changed 8 years ago by Leho Kraav

Cc: leho@… added

i am also experienced hangs at exactly 163840 bytes when doing ftpes. gnutls 2.12.16 with nettle 2.4. upgraded from gnutls 2.10 since filezilla 3.5.2 would just segfault when starting connecting to ftpes.

comment:8 Changed 7 years ago by pta

Cc: eko-priv@… added

Seems to me this regression is caused by a changed behavior of GnuTLS introduced in 2.12.x.

Additional information: https://savannah.gnu.org/support/?107660

Maybe the problem could be solved by moving to the new behavior?

comment:9 Changed 7 years ago by Kartik

I have the same problem with Filezilla 3.5.3 and gnutls 3.0.19 on arch.

comment:10 Changed 7 years ago by Andreas Prieß

Cc: ap@… added
Operating system version: Fedora 16Fedora 16 and Gentoo

I have the same problem on Gentoo Linux with filezilla-3.5.3 and gnutls-2.12.18. Available versions of gnutls-3.0* or 3.1* did not solve the problem.

Bug report for gentoo with my logs is here:
https://bugs.gentoo.org/show_bug.cgi?id=431404

comment:11 Changed 7 years ago by Andreas Prieß

Still does not work with version 3.6.0. and GnuTLS 3.1.4 on Gentoo Linux.

Changed 7 years ago by Andreas Prieß

Attachment: filezilla-3.6.0.log added

Filezilla-3.6.0 with GnuTLS 3.1.4 debug log with upload failing multiple times

comment:12 Changed 7 years ago by Andreas Prieß

This promlem ist fixed for me with filezilla 3.6.0.2.
Tested with gnutls-3.1.5 on Gentoo / amd64.

comment:13 Changed 6 years ago by pilou

This problem is fixed for me with filezilla 3.6.0.2.

Tested on Debian / amd64 with gnutls (2.12.20-6), the problem occurs with Filezilla 3.5.3-2 and doesn't occur with Filezilla 3.6.0.2-1.

comment:14 Changed 6 years ago by Alexander Schuch

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.