Opened 8 years ago

Closed 5 years ago

#7804 closed Bug report (fixed)

whitespace in filename cause download failure

Reported by: Chun-Hao Wu Owned by:
Priority: normal Component: FileZilla Server
Keywords: filename Cc:
Component version: Operating system type: Windows
Operating system version: 7

Description

I happen to have a file named ' 01.xxx.mp3' (xxx was Taiwanese).
The whitespace prefixing the file name causes downloading errors.
The filezilla server log shows the process.

(000005)2011/10/29 下午 23:56:44 - user (211.76.77.44)> 227 Entering Passive Mode (140,113,205,141,8,75)
(000005)2011/10/29 下午 23:56:44 - user (211.76.77.44)> RETR 01.xxx.mp3
(000005)2011/10/29 下午 23:56:44 - user (211.76.77.44)> 550 File not found

Yes, the filezilla client correctly requested the filename as 'RETR 01.xxx.mp3', which has two whitespaces after RETR.
It's just the server cannot find it.

The issue can be worked around by deleting the prefixing whitespace.
It's weird that when I tried to rename ' 01.xxx.mp3' to '01.xxx.mp3', windows 7 told me a file with that name already exists. I copied that file to the same directory, getting both '01.xxx.mp3' and ' 01.xxx.mp3'. Then, I deleted ' 01.xxx.mp3' and this time I can download '01.xxx.mp3' as usual.

So I'm unsure if this issue belongs to filezilla server or windows 7 or the FTP protocol.

Perhaps the problem is that all whitespaces between RETR and the filename are ignored by filezilla server?

Change History (1)

comment:1 Changed 5 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

This has been fixed a while ago.

Note: See TracTickets for help on using tickets.