Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#7803 closed Bug report (duplicate)

Wrong date - Same problem as Ticket #3698

Reported by: Frank S Owned by:
Priority: high Component: FileZilla Client
Keywords: date, month, year Cc: sdevoy@…
Component version: Operating system type: Windows
Operating system version: Win 7 Ultimate SP1 / 32-bit

Description

Same problem as Ticket #3698

I get wrong date when listing the remote directory.
sFTP on FreeFTPd ver 1.0.11 on win 2003 SP2
FileZilla Client is 3.5.1 running on windows 7
FreeFTPd is 1.0.11 on win 2003 SP2

From the log:


Command: pwd
Response: Current directory is: "/"
Command: ls
Status: Listing directory /
Status: Calculating timezone offset of server...
Command: mtime "2010-08-17"
Response: 4294967295
Status: Timezone offsets: Server: 1293629340 seconds. Local: 7200 seconds. Difference: -1293622140 seconds.
Status: Directory listing successful


The dates listed in FileZilla is wrong. 2011-10-28 are listed as 1970-04-04.
It can possibly be a problem in FreeFTPd, but WinSCP lists it correct.
In WinSCP there is a switch "Misinterprets file stamps prior to 1970". This is set to Auto in my case.
Would this be possible to implement in FileZilla?

Change History (2)

comment:2 Changed 6 years ago by Sean Devoy

Cc: sdevoy@… added
Priority: normalhigh

I have this problem, but I have detected an additional "requirement" to reproduce the problem. If the default directory on the server has a folder as the first item returned, the dates are all listed wrong. If the default folder starts with a FILE, the dates are all OK.

Hope that helps

comment:3 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #3698.

Note: See TracTickets for help on using tickets.