Opened 8 years ago

Last modified 7 years ago

#7758 new Bug report

ICO and other Images marked as ASCII rather than binary until toggled.

Reported by: sameer Owned by:
Priority: normal Component: FileZilla Client
Keywords: ascii, binary, image Cc: xaminmo@…
Component version: Operating system type: Windows
Operating system version: Window 7

Description

Whenever i upload images on any server all images get corrupted.
I uninstall and reinstall filezilla, but still problem is not solved, so please help me here what's wrong. Thanks.

Change History (2)

comment:1 Changed 8 years ago by Giles Birch

I have had this problem as well, and can provide more detail.
Filezilla 3.5.1, Windows 7 Pro 64-bit, uploading to Centos-based server.
Filename: favicon.ico
Transfer type: Auto
.ico is NOT on the list of extensions to be treated as ASCII.
File upload results in different size file (larger on server, oddly) and corruption of image.

If I un-check "Treat files without extension as ASCII file" the problem goes away. Curiously, if I re-check "Treat files...", the problem remains solved.

comment:2 Changed 7 years ago by Josh Davis

Cc: xaminmo@… added
Keywords: ascii binary image added
Priority: criticalnormal
Summary: Image corruptionICO and other Images marked as ASCII rather than binary until toggled.

Updating summary to better reflect problem.

I use Windows 7 x64 also, and do NOT have this problem.
However, on install, I re-enabled the "show icons for known file types".

Can you test if this change fixes your problem, and if setting it back breaks it again?

If so, this may be related to the procedure Fz uses to process/identify files in the command queue.

Note: See TracTickets for help on using tickets.