Opened 8 years ago

Closed 3 years ago

#7423 closed Feature request (rejected)

Requesting RS232 + CNC LVS2 transfer module

Reported by: scoubidou Owned by:
Priority: low Component: FileZilla Client
Keywords: serial, rs242, cnc Cc: xaminmo@…
Component version: Operating system type:
Operating system version: All

Description (last modified by Tim Kosse)

Should be interesting to add the V24/RS232 file transfert protocol. So, we could use Filezilla to transfert ISO files to CNC machines
, like these software for example :

Change History (7)

comment:2 Changed 8 years ago by scoubidou

Component: UnknownFileZilla Client
ip: 81.50.218.181
Priority: blockernormal
Resolution: wontfix
Status: closedreopened
Type: OtherFeature request

V24 protocol is still used in CNC and in industrial processus and will not be abandonned until at least 20 years.
Another transfert protocol that woulb be interesting too is EBICS.
This new protocol is used in Europe to transfert files to banks. It would be the only used protocol with Swiftnet and FTPS, after september 2011.
http://www.ebics.org/

comment:3 Changed 7 years ago by Josh Davis

Cc: xaminmo@… added
Resolution: Nonewontfix
Status: newclosed

I think we'd see iphone sync, direct PS to USB/Serial/Parallel printer, etc long before we saw raw serial uploads in CNC specific protocols.

I really don't think Filezilla is the proper tool for this.

If you can provide free equipment, detailed protocol specifications, and an indication that at least 0.5% of the FZ users would want this, then feel free to reopen this ticket for reassessment of the work effort required.

comment:4 in reply to:  3 Changed 7 years ago by scoubidou

Operating system version: All
Resolution: wontfix
Status: closedreopened

Replying to xaminmo:

I think we'd see iphone sync, direct PS to USB/Serial/Parallel printer, etc long before we saw raw serial uploads in CNC specific protocols.

I really don't think Filezilla is the proper tool for this.

If you can provide free equipment, detailed protocol specifications,

See http://jack.r.free.fr/index.php?lng=fr&page=rs232 and http://jack.r.free.fr/index.php?lng=fr&page=rs232_v3 , by Jack R., with documentation.

and an indication that at least 0.5% of the FZ users would want this, then feel free to reopen this ticket for reassessment of the work effort required.

Many non free softwares are sold, so they are enought users :

All of these softwares do the same thinks than FileZilla : adding FTP or RS232 connexions, connecting, transfering and viewing result of transferts in a file manager.
It should be possible to add a RS232 module, we would choose only between an FTP or a RS-232 connexion.

comment:5 Changed 7 years ago by Josh Davis

Keywords: serial rs242 cnc added
Priority: normallow
Status: reopenedmoreinfo_reopened
Summary: Adding V24/RS232 transfert protocolRequesting RS232 + CNC LVS2 transfer module

Simply pointing to paid RS232 software is not in any way helpful, nor is it applicable to your request.

If it were as simple as just having an RS232 connection, then why don't you use putty?

It's not that simple. Serial itself is not horribly difficult, and putty already has a serial module. FzClient already used putty for SFTP, so there's some synergy there.

The problem is, you don't transfer just magically transfer files over an RS232 connection. You have to use a serial transfer protocol. CNC uses its own protocol, that is not shared by any other type of equipment. Plus, each brand uses different protocol specifics. I don't mean 4800,8,N,1,CTS/RTS vs XON/XOFF, interpacket and intercharacter delays, etc. There are specific commands to make all of this work.

The references you provided are all PAY-FOR products. It's this way because the overall market is small, compared to the market for file transfers.

Let's make an analogy for your request. It's as if you walked into an appliance repair shop, and have insisted the repairman build you a car that converts into an certificated airplane. "It should be easy" you say, "because other people have airplanes, and I have a road near my house. As such, all 600,000 pilots in the US will want to use your custom, convertible airplane. You should also do this for free, in your spare time, and pay for all of the tools and equipment required to make this. Why would you NOT want to do this?"

All of your logic is skewed on this.

But, again, if you are willing to pay for and provide equipment which could be used for testing, and provide protocol specifications (API/Developer's guide or working code samples) for at least one of these machines, then I'm sure someone would be willing to work on it.

However, considering FileZilla doesn't presently have an RS232 module, nor any serial transfer protocols (X-Modem, Y-Modem, G and 1K variants, zmodem, puma, punter, kermit, etc), and those are used for a wide variety (thousands of models, millions of deployments) of computer equipment and communication systems, I seriously doubt CNC/cutter/slitter/engraver support (hundreds of of models, tens of thousands of deployments) would pick up developer support here unless one of the developers had a personal, vested interest in making it happen. Even so, they might make a separate, special purpose tool rather than muddy FileZilla with this.

The alternative is, if it's important to you, and little cost and effort for you, then you could write a patch which does what you need, and submit it for consideration.

I think you'll find that your request is along the order of 1000 hours for a skilled developer.

comment:6 Changed 7 years ago by scoubidou

Status: moreinfo_reopenedreopened

I did not simply pointed to paid RS232 software. During several days, I looked for and finally I found a free software (under GPL licence) to transmit files by RS232 protocol : please see http://jack.r.free.fr/index.php?lng=fr&page=rs232 and http://jack.r.free.fr/index.php?lng=fr&page=rs232_v3 , by Jack R., with documentation. Jack agreed to help programmers who will use its code.

Putty is only a console RS232 software, we can't use it to send files to a CNC machine. If you look at the others softwares, they are like FileZilla (a file manager + transfert protocol).
I know it would be a very big work to add these new RS232 protocols but the Filezilla interface can be keep. Perharps I could find a financial help in some months. Could you estimate the cost of this work, if you know people interested to work on it?

comment:7 Changed 7 years ago by Josh Davis

I missed that the Jack-R product was for CNC. That helps with one problem - reference code.

It's in TurboPascal, which would have to be ported or rewritten. Most of his documentation is on the serial communications itself.

Coding would need:

  • serial interface
  • CNC/DNC protocol handling
  • GUI enhancements to support the above
  • Test equipment

I don't know anyone interested, which is the problem. All of the developers need FTP and SFTP. FZ itself has an installed base in the millions. There's no info on how many of them might have a CNC lathe, but my guess would be few, with most of them building DiY kits.

While this is the proper place for such a request, it's truly just buried. I found this because I had too much caffeine and was surfing tickets. You may want to broadcast your request to a larger audience to see if you can get support for it.

As for financial help, that would still depend heavily on finding someone able and willing to assist. If you paid for it outright, you're looking at a year's salary for a good coder, plus one or two mills and somewhere to set them up, blank billets, etc. So it's better if you can find people to do this because they want to. They tend to do things for much less, or free.

I think the problem is that the available tools are "good enough" for the demand. Not great, and not ideal, but the cost of bumping up to the next level is above what the market wants to pay. Otherwise, people would just buy the paid GUI tools

Places to look for resources on this might be Jack R himself, or MAKE magazine forums, facebook, etc. Anywhere you can get enough audience where this might become a "cool project".

comment:8 Changed 3 years ago by Tim Kosse

Description: modified (diff)
Resolution: rejected
Status: reopenedclosed

Out of scope.

Note: See TracTickets for help on using tickets.