Opened 9 years ago

Closed 5 years ago

#7247 closed Bug report (fixed)

Speed limit icon isn't updated when changing themes

Reported by: starnixsa Owned by: Tim Kosse
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Linux
Operating system version: Ubuntu 10.10

Description

After changing the interface theme in settings, the icon bar icons are updated but not the icon for the speed limits. (see bug #5504, but for linux this time round)

Attachments (1)

update-statusbar-when-theme-changes.patch (2.0 KB) - added by Bruno Ramos 5 years ago.
[Patch] update status bar when theme changes

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by starnixsa

Priority: normallow

comment:2 Changed 5 years ago by Bruno Ramos

Confirmed.

This is happening again, tested on both windows and Linux with the latest version.

When changing the icon theme most icons are updated but not the one on the status bar for speed limits.

Changed 5 years ago by Bruno Ramos

[Patch] update status bar when theme changes

comment:3 Changed 5 years ago by Bruno Ramos

Owner: set to Tim Kosse
Status: newassigned

Small patch to fix this problem.
I was unable to update the icon in the existing status bar.
So I used the same solution as for some of the other components, delete the old status bar and put a new one in place.

Tested under Debian GNU/Linux only for the moment.

comment:4 Changed 5 years ago by Tim Kosse

Resolution: fixed
Status: assignedclosed

Patch rejected, it does not fix the underlying cause. The status bar itself is already reloading the icon if the theme option changes (see CStatusBar::OnOptionChanged)

The root cause is that the various option change handlers are getting notified in an undefined order. The solution is to preserve the relative order of the option change event handlers.

A fix for the latter has been committed to the repository.

Note: See TracTickets for help on using tickets.