Opened 9 years ago

Closed 9 years ago

#7177 closed Bug report (rejected)

Bugs in File-Zilla Client Software

Reported by: Bharat Sethi Owned by:
Priority: low Component: FileZilla Client
Keywords: Cc: bsethi24@…
Component version: Operating system type: Windows
Operating system version: Windows XP SP2

Description

Dear File-Zilla Development Team member,

Hi ! I am using File-Zilla for the first time & saw that it's a very nice tool. But, have 4 issues, which are as follows: -

  1. Due to any reason, if system get restarted or shut down, it don't keep the track that which of the files are in download/upload process, how much %age is completed & how much is remaining, how many files are their to be downloaded.
  1. Suppose a RAR/ZIP file is getting downloaded or uploaded & say it's size is 315 MB. If, in between Internet gets disconnected or by any reason Connection between Server-Client interrupted. Then after resume, File-Zilla continues the Download/Upload process even after 100% process graph & when we see the size of file at the download location then it's size is greater than original size & the file is of NO use.
  1. Verfication & Synchronization after download - both of these options are missing.
  1. If we set - "Action after Queue completion" to "Close File-Zilla" then it closes the File-Zilla software WITHOUT DISCONNECTING THE CONNECTION FROM SERVER. I personally saw this issue that after completion File-Zilla closes itself & when I check at the Server then in FTP current connection the connection is active. In this process, I suggest that after completion, File-Zilla first gets disconnected from Server & then closes itself. This process should be following in two more actions - Restart system & ShutDown system.

Waiting for positive reply.

Thanks & Regards,
Bharat Sethi

Change History (1)

comment:1 Changed 9 years ago by Tim Kosse

Priority: criticallow
Resolution: rejected
Status: newclosed

1) Please always cleanly shut down FileZilla. There is no reason for a modern computer to be shut down abruptly.

2) This is the result of using IIS as server. It is a very broken server, it claims to support resume, but does not actually resume. Use a different server and this problem will go away.

3) Not part of the FTP specifications

4) This is impossible using Windows' TCP/IP stack, thus cannot be caused by FileZilla. You are using a firewall and/or router that is silently dropping connections.

Note: See TracTickets for help on using tickets.