Opened 15 years ago

Closed 6 years ago

#606 closed Bug report (fixed)

Server: PORT does not accept IPs with leading zeros

Reported by: anonymous Owned by:
Priority: normal Component: FileZilla Server
Keywords: Cc: Tim Kosse
Component version: Operating system type:
Operating system version: Vollmer QW72P

Description

The FileZilla server can not open the data port when the
port command looks like:

PORT 192,168,160,010,80,51

Seems the leading zero in the 010 bothers him as
changing the IP to 100 worked well.

Just for the files: the client is a DEMAG injection
moulding machine with an NC4 controller running a
EuroMap63 protocol via FTP. They have a very lousy
FTP implementation and for now only Serv-U and FileZilla
(accept the mentioned flaw) work with it...

Change History (4)

comment:1 Changed 14 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

comment:2 Changed 7 years ago by Thomas Helbig

Operating system version: Vollmer QW72P
Status: closedreopened

This issue still exist, please change connection Problem on leading ZEROs in IP Adress.

comment:3 Changed 7 years ago by Alexander Schuch

Component: OtherFileZilla Server

comment:4 Changed 6 years ago by Tim Kosse

Resolution: fixed
Status: reopenedclosed

Will be fixed in the next version.

Note: See TracTickets for help on using tickets.