Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#5686 closed Patch (rejected)

improved SFTP upload performance patch

Reported by: BJB Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

Hi,

I realized a long time ago that uploads for SFTP were slower than they should be for connections that could benefit from large window scaling. The problem was in the PuTTY underlying code.

I finally dug out the source code to figure out why. Here is a patch that enables that behavior on Windows. I am using the patched version on my machine for a month now and I've not noticed any problems.

Regards

Attachments (1)

fz-windows-upload-speed.diff (944 bytes) - added by BJB 9 years ago.
patch

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by BJB

patch

comment:1 Changed 9 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

The change to the constants in ssh.c is basically a NOP as it is only used as fallback on servers that do not support large SSH windows.

There is no such thing as a "TCP send window scaling". A 4 MiB send buffer is detrimental to memory consumption and not really useful.

The default size of the send buffer on Windows which is a mere 8 KiB. So in each iteration through its sending loop, PuTTY can only send 8 KiB of data which induces additional delays which are the actual cause of the slowdown.
The true reason why it appears to work is that the default buffer size is a mere 8K under Windows.
A change to use slightly larger send buffer resulting in considerably improved transfer speeds has been committed to the SVN repository a while ago.

For future submissions, please carefully analyze the root cause of the problem and base your patch against the latest trunk head from the repository.

Note: See TracTickets for help on using tickets.