Opened 9 years ago

Closed 7 years ago

#5643 closed Feature request (duplicate)

"Check For Updates" Does Not Work When There Is A HTTP Proxy

Reported by: Tom Rausch Owned by:
Priority: low Component: FileZilla Client
Keywords: Check For Updates, HTTP Proxy Cc: igitur@…
Component version: Operating system type: Windows
Operating system version: XP

Description

I have to use a HTTP Proxy to communicate with the Internet; if I stop using the proxy and use a direct connection to the Internet, I cannot access HTTP via my Web browser.

Ever since I have had to use the HTTP Proxy, the "Check For Updates" cannot access the FileZilla information over the internet. Here is a log:

Status: Disconnected from server
Status: Downloading /updatecheck.php?platform=i586-pc-mingw32msvc&version=3.3.4.1&osversion=5.1&osarch=32
Status: Resolving address of update.filezilla-project.org
Status: Connecting to 62.75.138.232:443...
Status: Connection attempt failed with "ETIMEDOUT - Connection attempt timed out", trying next address.
Status: Connecting to 213.239.222.5:443...
Status: Connection attempt failed with "ETIMEDOUT - Connection attempt timed out".
Error: Disconnected from server: ETIMEDOUT - Connection attempt timed out
Error: Disconnected from server
Error: File transfer failed

However, when I access the URL
"https://62.75.138.232/updatecheck.php?platform=i586-pc-mingw32msvc&version=3.3.4.1&osversion=5.1&osarch=32" from IE, which is using a HTTP proxy, I obtain a respose; here is the response:

nightly 2010-10-19 http://filezilla-project.org/nightlies/2010-10-19/i586-mingw32msvc/FileZilla_3_setup.exe sha512 365565943362ae605ae680c09c9260c1dbc915d11d63899700f304a85cb5090f0d257f9096e608bf1c731297ba843677d1d0b81d93cc829edfae4fbcdc7484a1
release 3.3.4.1 http://downloads.sourceforge.net/filezilla/FileZilla_3.3.4.1_win32-setup.exe sha512 d4e0b0eaf4f3767e37df12063e7d79f74ac8005535e829b99e1feb0f0541c3343570fc892e020f99087d31de20d01e797d7476ab2cfd94c28a78d0e8b732e0cd

Can the "Check For Updates" be modified to use a HTTP Proxy, either using the one configured in IE or one configured separately in FileZilla?

Tom Rausch

Change History (2)

comment:1 Changed 9 years ago by Francois Botha

Cc: igitur@… added

comment:2 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #4508.

Note: See TracTickets for help on using tickets.