Opened 9 years ago

Closed 7 years ago

#5576 closed Feature request (duplicate)

configuration of file list sorting algorithm

Reported by: Florian Mayer Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type:
Operating system version:

Description

Found a bug in the newest FileZilla Version for Mac (I don't know if the bug also exists in the Windows version):

I have a lot of files on my server. Some start with a lowercase "c" and some with an uppercase "C". Now, the uppercase "C" is listed on top of all lowercase files.
Maybe there should be an option, if the start-character style should be ignored.

This bug really sucks, but maybe it's a "feature". That wouldn't be good!

Thank you very much,
Florian!

Sorry about my bad english. I'm from germany.

Change History (3)

comment:1 Changed 9 years ago by eastwood

Same issue here. Filename sort order puts all filenames starting with a capital letter before all those starting with lowercase letters.


FileZilla Client


Version: 3.3.4.1

Build information:

Compiled for: i486-pc-linux-gnu
Compiled on: i486-pc-linux-gnu
Build date: 2010-08-22
Compiled with: gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.10
GnuTLS: 2.8.5

Operating system:

Name: Linux 2.6.32-24-generic-pae i686
Version: 2.6

comment:2 Changed 7 years ago by Alexander Schuch

Operating system type: OS X
Operating system version: 10.6.4
Summary: Wrong file sort orderconfiguration of file list sorting algorithm
Type: Bug reportFeature request

I merge this case together with #7996.

This is not a bug but a feature request. And it is about configuring file list sorting.

It should be possible to sort case-sensitive or case-insensitive and possibly with natural order or without.

comment:3 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #2978.

Note: See TracTickets for help on using tickets.