Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5563 closed Bug report (fixed)

Wrong filesize shown (2 GB for a file of 1.079.192 bytes)

Reported by: BurninLeo Owned by:
Priority: normal Component: FileZilla Client
Keywords: filesize Cc:
Component version: Operating system type: Windows
Operating system version: Vista

Description

Hello,

I recently wondered that a file that should be around 1 GB was shown as "2 GB" in the FileZilla Client v3.3.4.1. After downloading from the Linux/Debian server, the file also had "2 GB" on the local disc - according to FileZilla Client. However the Windows Explorer is quite sure that it actually only has 1.02 GB.

If I change to more than 0 decimals in the settings, FileZilla shows a size of 1.03 GB. Therefore I guess FileZilla rounds up the filesize in a suboptimal way.

BurninLeo

Change History (2)

comment:1 Changed 10 years ago by Tim Kosse

Priority: highnormal
Resolution: fixed
Status: newclosed

This is by design. File sizes should never be rounded down, as the size of a file determines its cost in terms of storage, traffic and so on.

I do agree however that the default of 0 decimal places is suboptimal, so the next version of FileZilla will default to 1.

comment:2 Changed 10 years ago by BurninLeo

Sorry, I did not mean to set this issue on "high" priority - my fault.

Other software seems not to consistently share the principle of rounding up, however, the argumentation is sensible. Your solution to set one decimal per defaults seems a good one to prevent further irritation :)

Note: See TracTickets for help on using tickets.