Opened 9 years ago

Closed 9 years ago

#5558 closed Feature request (duplicate)

Show agregate speed on status bar (and on a tab)

Reported by: Adem Meda Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: adem.meda@…
Component version: Operating system type: Windows
Operating system version:

Description

As we all know, FileZilla is more than simply an ftp client (or server), it is sometimes also used as common yardstick to see how the connection between the client and server is performing.

IOW, performance figures from FileZilla get used as data to help optimize the network/server.

Case 1) When I complained to my ISP that their line wasn't performing, they asked me to connect to their ftp servers (they specifically requested that I use FileZilla) and start simultaneously downloading 10 test files from their server.

Case 2) When I set up a server myself, I usually use FileZilla to see how it is performing, and compare FileZilla results with other transfer methods (SCP, Samba etc).

To help with these, it would be great if FileZilla could display aggregate speed (of all currently active transfers) on the status bar.

It would be even more great if there was a new tab (beside 'Queued Files', 'Failed Transfers', 'Successful Transfers') that showed a graph of speeds for individual transfers as well as aggregate.

Change History (2)

comment:1 Changed 9 years ago by Adem Meda

Cc: adem.meda@… added

comment:2 Changed 9 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #1982

When I complained to my ISP that their line wasn't performing, they
asked me to connect to their ftp servers and start simultaneously
downloading 10 test files from their server.

If a single transfer doesn't max out the connection, their line already isn't performing. Using multiple transfers only masks out a real problem.

Note: See TracTickets for help on using tickets.