Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#5383 closed Bug report (rejected)

multiple concurrent uploads fail with SFTP

Reported by: Rasmus Schultz Owned by:
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Vista

Description

This may be related to this bug:

http://trac.filezilla-project.org/ticket/3477

Two years old and long since closed, but this appears to be the same (or a similar) issue.

Uploading multiple files in multiple folders, over SFTP, with multiple concurrent uploads (5 is my setting), doesn't work with all servers.

The problem is, the client makes no intelligent decisions about the order in which uploads are processed.

That is, if you're uploading "folder_a/file_a" and "folder_a/file_b", the order in which these happen to occur, is unpredictable - it depends on whether or when a thread happens to be available.

So when "file_a" begins to upload, the folder is created - but if at the same time "file_b" begins, and assumes the folder has been created, but the previous request didn't complete yet, it will fail.

Change History (2)

comment:1 by Tim Kosse, 5 years ago

Resolution: rejected
Status: newclosed

From the NewTicketFormGuide: "Priority: Leave it at normal, even if the problem is important for you. The developers will decide how important this problem really is."

"Tickets that are filled out incorrectly will get rejected."

comment:2 by Tim Kosse, 5 years ago

Priority: criticallow
Note: See TracTickets for help on using tickets.