Opened 10 years ago

Closed 7 years ago

#5347 closed Bug report (rejected)

Windows 7: network card crashes on multiple connections

Reported by: Conrad Owned by:
Priority: normal Component: FileZilla Client
Keywords: windows 7, network card, crash, reboot, multiple connections Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 64bit Professional Version 6.1 (Build 7600)

Description

In the current release 3.3.2.1 on my win7 x64 system I recognized a strange behaviour that causes my wired network card to "crash" which gets only working again after a reboot.

Following is happening, I reproduced it as described about 5 times:
Downloading a huge amount of files and data from a standard webserver. To increase the overall speed, I usually download several files at a time time, mostly about 4. When 1 *bigger* file is currently downloading (> 40MB) and other *little* ones (> 5KB & < 100KB) are downloaded too, it stucks from *one moment to the other*.
The described issue results in a completely freezed network card. No connections can get in or out anymore. From then it is impossible to change the IP address manually (or automatically), enable/disable it to refresh the network card or even send a ping to a known computer in the network. It seems that only a reboot of the system does help (if windows shuts down correctly, otherwise human needs to be stronger than computer by pressing the power off button)

(In the past I had a similar problem too, which was caused of too many open ftp connections because of many little files and an overhead for tcp connections, which then resulted in a stopped queue. But this queue could be continued after some minute when the server has ended all open connections in timeout and other network functions still worked.)

As already mentioned, I reproduced this about 5 times and while trying to find out if this can be avoided, following helps a bit:

  • Downloading only 1 file at a time -> many big files are not a problem, only small files even don't. Only the combination of *some* large and many small ones make trouble.
  • While downloading, I watched the queue and when a big file is currently running, I manually changed the options to 1 file so that the small files currently downloading get finished and then only the big one is left -> it worked without a problem. After the big file was finished, I switched to multiple downloads again until the next big one was coming. That was a bit annoying but still increases the overall download speed (for 4000 files)

Below is the currently used filezilla version, if you need additional detailed hardware/os information (dxdiag whatever) or more information that I might have forgotton here, let me know.

Thanks.
btw. I really really like filezilla! great job :)

Conrad


Version: 3.3.2.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2010-03-21
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.11
GnuTLS: 2.8.3

Change History (1)

comment:1 by Alexander Schuch, 7 years ago

Resolution: rejected
Status: newclosed

This looks like a buggy network driver. For an analogy, have a look at comment 3 of #8565.

Note: See TracTickets for help on using tickets.