Opened 7 years ago

Closed 6 years ago

#8565 closed Bug report (rejected)

Windows 8 OS crash upon transfer of >2GB file

Reported by: fztracjn Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Windows 8 64-bit Professional (9200.16496.amd64fre.win8_gdr.130108-1504)

Description

This issue is 100% reproducible. Windows 8 64-bit will crash during the following conditions.

  1. Have a file larger than 2GB available. (Test file I used was 2.4GB). Be connected to a valid remote FTP site.
  2. Use FileZilla Portable 3.6.0.2.
  3. From the OS (not from the "Local Site" pane in FileZilla), drag the file to the "Remote Site" window.
  4. Watch as the Windows 8 operating system crashes and your computer reboots.

I have attached an example minidump file for analysis.

Attachments (1)

031513-6953-01.dmp (172.3 KB) - added by fztracjn 7 years ago.
example minidump file for condition described

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by fztracjn

Attachment: 031513-6953-01.dmp added

example minidump file for condition described

comment:1 Changed 7 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Normal programs cannot crash an entire operating system unless the operating itself or one of its drivers is faulty. Contact your operating system vendor for assistance.

comment:2 Changed 7 years ago by fztracjn

Resolution: rejected
Status: closedreopened

This is the only application, among literally 174 installed applications on my main workstation, that causes the issue.

I can reliably cause the issue to replicate again and again on several Windows 8 systems.

How can you dismiss this as an "operating system" issue?

comment:3 Changed 6 years ago by Alexander Schuch

Resolution: rejected
Status: reopenedclosed

Let's put up an analogy:

Assume there is a glass vendor who says "My glass is unbreakable!" - without any small print and without and further limitations. Now, imagine you are able to reproducibly break the glass. Is it your fault because you are able to break it or is it the fault of the glass vendor who gave false promises?

Modern operating systems separate applications from real hardware by providing driver APIs, separating applications from each other using memory mapping and protection techniques and in general remain full control of what is running (preemptive multitasking). This is the promise the OS gives.

So if an application (NOT a hardware device driver) is able to crash the OS, the problem is with the OS and not with the application. So maybe you use the same faulty hardware device driver on all systems and FileZilla is the only application which actually triggers buggy code inside such a driver?

And from all your 174 applications, FileZilla likely is the only FTP application. So what? Application do different things in a different way. They use different code, trigger different conditions and require different drivers. A program to configure your mouse speed and double click rate simply won't trigger bugs in network or audio drivers.

comment:4 Changed 6 years ago by fztracjn

Resolution: rejected
Status: closedreopened

Fair enough, and I appreciate the analogy.

I work in software development and am sympathetic with the need to reduce responsibility surface area for your codebase. I suppose my request is more along the lines of: "Can we figure out what's specifically causing this so we can report it to Microsoft, if necessary?"

In my experience, when a piece of software demonstrates a catastrophic failure like this, even if it is the fault of the OS, the third-party software supplier generally makes an effort to isolate the issue and work toward a fix. Whether it's Filezilla's fault or not, users who experience a blue-screen restart (almost completely unheard of in Windows 7/8) will probably assume that Filezilla has the problem and simply discontinue using it.

I don't have the time to develop the expertise to analyse the Windows executable and attempt to ascertain what is causing the issue. Hence, I opened this ticket.

Maybe you'll want to close it as "rejected" again, but it would be great if we could identify the underlying cause rather than just ignore the issue.

comment:5 Changed 6 years ago by Alexander Schuch

Priority: blockernormal

comment:6 Changed 6 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed
Note: See TracTickets for help on using tickets.