Opened 10 years ago

Closed 10 years ago

#5293 closed Bug report (worksforme)

ssl cerification

Reported by: Csaba Csik Owned by:
Priority: low Component: FileZilla Client
Keywords: ssl Cc:
Component version: Operating system type: Windows
Operating system version: windows xp

Description

I have a valid ssl certification on my server. I connect filezilla cliet TLS and i have to accept this cert. WHY? My browser accept automatic this cert. I need to the client use microsoft cert store. How to it?

Change History (1)

comment:1 by Tim Kosse, 10 years ago

Resolution: worksforme
Status: newclosed

This is by design.

Your certificate may be valid, but is it authentic? Only safe way is for you to check that using the presented information.
Browsers on the other blindly trust some certificate authorities to decide the authenticity. Problem with that is simple, all it takes is a single compromised CA to completely undermine the trust model. FileZilla prevents this by always prompting the user to actually verify the certificate.

Note: See TracTickets for help on using tickets.