Opened 11 years ago

Closed 11 years ago

#5292 closed Bug report (rejected)

Access to special path failed if the folder name has an extra space at the end

Reported by: Alex Zhou Owned by:
Priority: normal Component: FileZilla Client
Keywords: folder name extra space Cc:
Component version: Operating system type: Windows
Operating system version: Windows XP, Vista and 7

Description

Thread recap:

Access to below folder path failed, the folder ”First vendor” was created by the vendor.

/First vendor

Command: CWD First vendor
Response: 550 Failed to change directory.
Error: Failed to retrieve directory listing

The problem is that the folder “First vendor” has an extra space at the end, so it was actually “First vendor ”, but we cannot see that in FileZilla client, and we cannot rename or delete the folder.

The folder can be accessed using other FTP software like “Leechftp”.

Change History (1)

comment:1 by Tim Kosse, 11 years ago

Resolution: rejected
Status: newclosed

You are using an older server that does not support MLSD. On such servers FileZilla has to fall back to LIST to obtain directory listings. Unfortunately LIST output is not standardized. As such, leading and trailing spaces in filenames are indistinguishable from padding characters.

Please either update to a server supporting MLSD or refrain from using leading/trailing whitespace.

Note: See TracTickets for help on using tickets.