Opened 9 years ago

Closed 9 years ago

Last modified 5 years ago

#5266 closed Bug report (duplicate)

FileZille not recognizing new file associations...

Reported by: Andrew Owned by:
Priority: normal Component: FileZilla Client
Keywords: file association error Cc:
Component version: Operating system type: Windows
Operating system version: Win XP SP3

Description

I recently changed file associations for my PHP files and FileZilla doesnt seem to recognize the association change. I use to be able to right click and open PHP files just fine but since the old programs deletion and file assocation change I can't right click and open my PHP files from FileZilla any more. Please see the attached picture for the error / message that I am getting.

Ty for your time and interest.

Attachments (1)

fileassociationerror.png (11.2 KB) - added by Andrew 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by Andrew

Attachment: fileassociationerror.png added

comment:1 Changed 9 years ago by Andrew

Keywords: file association error added

comment:2 Changed 9 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

DDE associations are a known problem. There are already several other tickets about this.

As workaround, use a non-DDE association.

comment:3 Changed 9 years ago by Andrew

Wow, people were right... you guys dont help. Just close stuff out with a "canned" answer.

comment:4 Changed 9 years ago by Andrew

Resolution: duplicate
Status: closedreopened

comment:5 Changed 9 years ago by Andrew

Also, Just because it might be a duplicate doesnt give you the right to just ignore it without even suggesting a "hotfix" which I know you guys have... even if it is a registry hack/edit.

comment:6 Changed 9 years ago by Tim Kosse

Resolution: duplicate
Status: reopenedclosed

I was not a canned response, it was hand-written. Regardless, that does not change the fact that this report is a duplicate. See for example #5135. I gave you a "hotfix" by telling you to not use DDE associations for now.

comment:7 Changed 9 years ago by Andrew

Resolution: duplicate
Status: closedreopened

Ok, Maybe I was wrong with the canned thing but the fact remains is that your assuming I even know what a DDE association is.

I was using Antechinus PHP editor now I'm using their new JS/PHP combined editing program.

For arguments sake, off the top of your head. Why won FZ seem to recognize the new file assocation sicne everything else I have does ?

comment:8 Changed 9 years ago by Tim Kosse

Resolution: duplicate
Status: reopenedclosed

Still a duplicate of #5135.

FileZilla just cannot handle DDE associations yet. Note that since FileZilla is cross-platform it needs to do a lot of things in a slightly different way and cannot rely too much on Windows-specific functionality. As such the associations have to be parsed manually. I simply did not have the time needed to investigate DDE support. Frankly, I do not even know a single program that uses DDE, everything I use uses regular associations.

Note: See TracTickets for help on using tickets.