Opened 10 years ago

Closed 6 years ago

#5223 closed Feature request (duplicate)

File list alphabetical sort order differs from windows explorer

Reported by: Ralph Sleigh Owned by:
Priority: normal Component: FileZilla Client
Keywords: file sort order Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 Professional x64

Description

Given a folder with 4 files, Windows (7|server 2003) will sort them

-.txt
a.txt
aa.txt
a-b.txt

The FileZilla listing is ASCII order: (As does Ubuntu)

-.txt
a-b.txt
a.txt
aa.txt

This may be a won't fix, but in an ideal world an application will use the OS sort order, so thought I would throw this out here. In my Drupal theme directory with about 100 files along the lines of 'views-view-field--gigs-display--page-1--field-artistref-nid-1.tpl.php', having FileZilla sort them differently from explorer is annoying.

FileZilla Client


Version: 3.3.2

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2010-02-21
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.11
GnuTLS: 2.8.3

Change History (2)

comment:1 Changed 6 years ago by Alexander Schuch

Type: Bug reportFeature request

comment:2 Changed 6 years ago by Alexander Schuch

Keywords: file order added; win7 alphabetical removed
Resolution: duplicate
Status: newclosed

This is a duplicate of #2978.

Right now FileZilla lacks support for selecting a collation to be used for sorting.

Note: See TracTickets for help on using tickets.