Opened 10 years ago

Last modified 8 years ago

#5200 reopened Bug report

Can't list files from a server with Compaq Tru64 UNIX Version 5.60 using TYPE I

Reported by: Hans S Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: sms@…
Component version: Operating system type: Windows
Operating system version:

Description

Can't list files when the "TYPE I" is selected. It will only work with clients that use "TYPE A" for file list. Could some one add an option to use "TYPE A" for file lists instead of "TYPE I"?

220 statne95 FTP server (Compaq Tru64 UNIX Version 5.60) ready.
Kommando: USER ides
Svar: 331 Password required for ides.
Kommando: PASS *
Svar: 230 User ides logged in.
Status: Ansluten
Status: Hämtar kataloglistning...
Kommando: PWD
Svar: 257 "/usr/users/ides" is current directory.
Kommando: TYPE I
Svar: 200 Type set to I.
Kommando: PORT 127,227,226,148,13,204
Svar: 200 PORT command successful.
Kommando: LIST
Svar: 150 Opening BINARY mode data connection for /bin/ls (127.227.226.148,3532).
Svar: 451 Local resource failure: malloc: No such device or address.
Kommando: LIST
Svar: 425 Can't build data connection: Connection refused.

Change History (2)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Your client is not configured correctly. Please read http://wiki.filezilla-project.org/Network_Configuration

comment:2 Changed 8 years ago by Steven Schweda

Cc: sms@… added
Resolution: rejected
Status: closedreopened
Type: Feature requestBug report

A similar complaint recently appeared on an HP user forum:

http://h30499.www3.hp.com/t5/x/x/m-p/5308399

So far as I can see, a binary ("TYPE I") request for a "LIST" violates
the RFC. That may help to explain why, of the six simple FTP clients
which I tried, every one worked better than FileZilla on this particular
(Tru64) FTP server.

Your client is not configured correctly. Please read
http://wiki.filezilla-project.org/Network_Configuration

Really? And what useful thing will that tell me? (I didn't
immediately spot anything in there which applied to this situation.
Please help me out.)

Note: See TracTickets for help on using tickets.