Opened 10 years ago

Closed 10 years ago

#5182 closed Bug report (duplicate)

Return to parent directory

Reported by: Zsolt Zimmermann Owned by:
Priority: normal Component: FileZilla Client
Keywords: file browser panels Cc:
Component version: Operating system type: Windows
Operating system version: all

Description

This has been ticketed as feature requests before under http://trac.filezilla-project.org/ticket/1878 but I think it is a bug.

On returning to parent directory FileZilla jumps to the first entry on the file list but should stay on the folder just exited.

See standard file browser apps how to behave. Navigating with keyboard is essential in a utility like this.

Regs,
Zsolt.

Change History (8)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Can't be a bug because it's not a feature that misbehaves. It's a feature request since there is no such feature at all. Hence still a duplicate of #1878.

comment:2 Changed 10 years ago by Zsolt Zimmermann

Component: FileZilla ServerFileZilla Client
Keywords: panels added; remote removed
Resolution: duplicate
Status: closedreopened

Hi!

I think you're correct of browsing a standard file structure is not a feature as it is a basic functionality of a software. Ergo it is really not a feature request at all.

Meanwhile I discovered the same behaviour in the local file browser panel. Exiting to parent folder pops to the first entry of the parent and do not stay at the current one. MS Explorer or any Linux OS file browser apps do like this (even Total Commander itself). So I think it is a 7 year old bug.

Best whishes,
Cina.

comment:3 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: reopenedclosed

How can it possibly be a bug if it concerns a feature that isn't even there in the first place?

It's like saying "The jet engine in my car is broken" if your car doesn't have a jet engine in the first place.

comment:4 Changed 10 years ago by Zsolt Zimmermann

Ok, I don't want to argue, but if we are in the mood of metaphores it's much more like a corridor with a lot of doors: You enter a room through the door No 100 but when you exit it you are at the really beginning of the corridor. You have to walk again down 100 doors to enter 101. It is not a feature that I request of doors it's only a normal, BASIC behaviour. So it's up to you to neglegt something that was invented in the first graphical OS back in 1980s.

Not want to be mean or rude but to help. Really.
Cina.

comment:5 Changed 10 years ago by Zsolt Zimmermann

Resolution: duplicate
Status: closedreopened

comment:6 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: reopenedclosed

Ok, I don't want to argue

Good. Since you do not appear to be a software developer, please take my word for it that this is a feature request and not a bug.

comment:7 Changed 10 years ago by Zsolt Zimmermann

Resolution: duplicate
Status: closedreopened

Good. Since you do not appear to be a software developer, please take my word for it > that this is a feature request and not a bug.

Now you're wrong. I'm indeed a dev. That is why I'm so notorious about it. It would be one or two line of code to save the child folder name to a variable and select the list item you just saved.

No more writing. Bye.

comment:8 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: reopenedclosed

It would be one or two line of code to save the child folder name to a variable and select the list item you just saved.

In other words, adding functionality, not correcting existing functionality. Once again, feature request.

Note: See TracTickets for help on using tickets.