Opened 10 years ago

Closed 10 years ago

#5158 closed Bug report (duplicate)

Leading blank (again)

Reported by: abdolo Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Seven/Vista x86/x64

Description

This is not the problem tracked and solved (I searched). This is a new one.
Using 3.3.1.
When on the remote side there is a file that has a leading blank in the name AND the first letter is a capital one, transfer fails.
Using ftpd on FreeBSD 7.2 p4 x86 on remote server.
Steps to reproduce:

  • go in console on the ftp server and enter the ftp root
  • cp any file from the system: cp /var/log/messages .
  • from the client all works ok and can transfer messages file
  • mv messages \ messages
  • from the client it is ok again, with leading space
  • mv \ messages \ Messages
  • the client fails to transfer the file

Tried with any kind of file/permission combo, blank+capital seems to be the culprit.
HTH
Bye

Attachments (3)

ftpd_session_f.pcap (1009 bytes) - added by abdolo 10 years ago.
Wireshark session
filezilla_client.txt (231 bytes) - added by abdolo 10 years ago.
Logs from Filezilla
RightPane.PNG (8.4 KB) - added by abdolo 10 years ago.
Left aligned remote file

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Please attach complete logs.

Changed 10 years ago by abdolo

Attachment: ftpd_session_f.pcap added

Wireshark session

Changed 10 years ago by abdolo

Attachment: filezilla_client.txt added

Logs from Filezilla

comment:2 Changed 10 years ago by abdolo

Status: moreinfonew

The problem is pretty straight: having the space in front of the file, FileZilla issues a request for the wrong file name
RETR Messages
should be RETR \ Messages

comment:3 Changed 10 years ago by abdolo

Also worth to note: in the remote files pane, I see clearly the " Messages" files is left aligned with the others, with no space in front.

Changed 10 years ago by abdolo

Attachment: RightPane.PNG added

Left aligned remote file

comment:4 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Please attach complete logs, snippets are of no use. If possible, enable "Show raw directory listings" in the settings dialog of FileZilla.

comment:5 Changed 10 years ago by abdolo

Status: moreinfonew

Here you are. File names are sent ok. Also to note that IE, FireFox, Squid, BSD ftp treat the file name correctly.

Status: Connection established, waiting for welcome message...
Response: 220 compilo.angaru.pizza FTP server (Version 6.00LS) ready.
Command: USER cello
Response: 331 Password required for cello.
Command: PASS
Response: 230 User cello logged in.
Command: SYST
Response: 215 UNIX Type: L8 Version: BSD-199506
Command: FEAT
Response: 211- Extensions supported:
Response: MDTM
Response: REST STREAM
Response: SIZE
Response: 211 End.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/usr/home/cello" is current directory.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (10,136,1,104,209,177)
Command: LIST
Response: 150 Opening BINARY mode data connection for '/bin/ls'.
Listing: total 184
Listing: -rw-r--r-- 1 root cello 76263 Feb 2 14:13 Messages
Listing: -rw-r--r-- 1 cello cello 758 Jan 2 11:00 .cshrc
Listing: -rw-r--r-- 1 cello cello 258 Jan 2 11:00 .login
Listing: -rw-r--r-- 1 cello cello 167 Jan 2 11:00 .login_conf
Listing: -rw------- 1 cello cello 379 Jan 2 11:00 .mail_aliases
Listing: -rw-r--r-- 1 cello cello 339 Jan 2 11:00 .mailrc
Listing: -rw-r--r-- 1 cello cello 773 Jan 2 11:00 .profile
Listing: -rw------- 1 cello cello 284 Jan 2 11:00 .rhosts
Listing: -rw-r--r-- 1 cello cello 980 Jan 2 11:00 .shrc
Response: 226 Transfer complete.
Status: Calculating timezone offset of server...
Command: MDTM Messages
Response: 550 Messages: No such file or directory.
Status: Directory listing successful
Status: Connecting to 10.136.1.104:21...
Status: Connection established, waiting for welcome message...
Response: 220 compilo.angaru.pizza FTP server (Version 6.00LS) ready.
Command: USER cello
Response: 331 Password required for cello.
Command: PASS
Response: 230 User cello logged in.
Status: Connected
Status: Starting download of /usr/home/cello/Messages
Command: CWD /usr/home/cello
Response: 250 CWD command successful.
Command: PWD
Response: 257 "/usr/home/cello" is current directory.
Command: TYPE A
Response: 200 Type set to A.
Command: PASV
Response: 227 Entering Passive Mode (10,136,1,104,239,44)
Command: RETR Messages
Response: 550 Messages: No such file or directory.
Error: Critical error

comment:6 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #3032.

Using LIST it is impossible to distinguish leading spaces from padding. You have to upgrade to a server supporting MLSD or refrain from using such exotic filenames.

Note: See TracTickets for help on using tickets.