Opened 9 years ago

Closed 6 years ago

#5157 closed Feature request (duplicate)

auto-upload modified files settings

Reported by: Dave Miller Owned by:
Priority: normal Component: FileZilla Client
Keywords: automatic upload, external edit Cc:
Component version: Operating system type:
Operating system version:

Description

Settings -> File Editing

It would be nice if current checkbox:

[ ] Watch locally edited files and prompt to upload modifications

were broken into two checkboxes:

[ ] Watch locally edited files and upload modifications

[ ] Prompt before upload

I want locally modified files to upload without a prompt.

Thanks and keep up the good work!

Dave Miller

Change History (5)

comment:1 in reply to:  description Changed 9 years ago by Chris

Replying to mildavw:

Settings -> File Editing

It would be nice if current checkbox:

[ ] Watch locally edited files and prompt to upload modifications

were broken into two checkboxes:

[ ] Watch locally edited files and upload modifications

[ ] Prompt before upload

I want locally modified files to upload without a prompt.

Thanks and keep up the good work!

Dave Miller

Not sure if this is the right place, but I'd like to see that also, and in addition a window to manage files that are currently being edited (to stop monitoring, local file location, remote location, etc)

Chris

comment:2 Changed 9 years ago by Jari Pennanen

Old issue, see a big feud at #4694.

To conclude the discussion or continue rant here, there is a slight risk (other equally big risk I presume is being hit by meteor) when the auto-uploader overwrites the file someone might be editing in remote... And throwing the prompt somehow makes the FileZilla less responsible of this overwriting, since the user pressed Ok in the first place. But this ain't politics, there could be option. If I want to pee in my cup of tea, I very well should be allowed god dammit.

P.S. I would too like to see the prompt banished.

comment:3 Changed 9 years ago by Dave Miller

Wow. Interesting. Thanks for the link.

I have to agree with everyone - 1 over there: every other FTP client manages to make it work. Let's let the users live dangerously if they chose. Make the default the "safer" setting.

comment:4 Changed 9 years ago by Chris

The thing that makes it dangerous for me is if you "edit" a local file whilst the remote pane is in the wrong directory. It's very difficult to actually see where the file is being uploaded, especially if you've subsequently browsed remotely to the correct directory. Editing the local file again doesn't update the remote location either...

I think an option to "auto upload this file" would be no worse than an annoying warning dialog that isn't big enough to read the full local and remote paths on anyway.

Chris

comment:5 Changed 6 years ago by Alexander Schuch

Keywords: automatic upload external edit added
Operating system type: Windows
Operating system version: XP
Resolution: duplicate
Status: newclosed

This is a duplicate of #2914.

Note: See TracTickets for help on using tickets.