Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5077 closed Bug report (rejected)

Cannot download the file with foreign characters

Reported by: Thomas Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 (64-bit)

Description

Server ftp in UTF8 mode.
The problem is that I have many files with the same foreign char in name (as ą or ł or ć or ż, etc.) but only a few of them (of files) are not able to download.
So when I take such kind of file from "failed transfers" and rename it (get rid of the char from name) and restore back the name (again rename and write the missing char) I'm able to download this file.

Attachments (2)

ftp-log.txt (2.5 KB) - added by Thomas 10 years ago.
log from filezilla
filezilla.log (28.2 KB) - added by Thomas 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by Thomas

Attachment: ftp-log.txt added

log from filezilla

Changed 10 years ago by Thomas

Attachment: filezilla.log added

comment:1 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

IIRC vsftpd supports UTF-8 only in the way that is passes it through to the underlaying filesystem.

How were those files created on the server in the first place?

comment:2 Changed 10 years ago by Thomas

Unfortunately, it is difficult to determine because it is not my server (but the problem I meet very often so I was wondering if filezilla does not know a cure for this problem).

How are created ... by different ftp clients, the PHP environment (for example, by joomla) or directly.

comment:3 Changed 10 years ago by Thomas

And one important observation, it seems that in an earlier version of FileZilla (2.x), this problem does not occur, like using other ftp clients the problem is not noticeable, there is only in FileZilla 3.x

comment:4 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: moreinfoclosed

This confirms it, those files were almost definitely created using the wrong character set. Please delete them and re-upload them using FileZilla so that the proper encoding is used. In case you delete them using FileZilla, restart it between deletion and reupload.

comment:5 Changed 10 years ago by Thomas

Ok but why other ftp clinet works well? and the old filezilla also works correctly!

comment:6 Changed 10 years ago by Tim Kosse

Pure luck. Those other clients and also the old FileZilla are in violation of the FTP standard. What happens then is purely undefined, anything could happen.

Note: See TracTickets for help on using tickets.