Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#5064 closed Bug report (rejected)

FZ damages network connection on Win7, freezes on WinServer08R2

Reported by: Felix Owned by:
Priority: normal Component: FileZilla Client
Keywords: system crash network connection Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 / Windows Server 2008 R2, both with all available updates

Description

My Setup:
FileZilla Client 3.3.0.1 on Windows 7 and Windows Server 2008 R2, Apple's FTP sharing server on MacOSX 10.6.2, working in gigabit local area network.

After I updated FileZilla to the current version on Win7, I successfully transfered 5 files to the FTP server. It was always the same file, I just modified it multiple times between the uploads. So after uploading this file 5 times, I tried to upload it another time. FileZilla tried to start the download, but instantly after starting, the network connection gets broken - I don't have any connection to my network now. I can use Windows' "troubleshoot problems" feature from the network icon's context menu, which will say the following:

Problems found
The connection between your access point, router, or dable modem and the Internet is broken -- Detected
The default gateway is not available -- Fixed

After that, the network connection works fine. But as soon as I start a transfer with FileZilla, it breaks every time. This is permanent, restarting FileZilla or rebooting Windows does not help.

FTP transfers with the Windows Explorer work fine.

I also tested this on Windows Server 2008 R2. The issue is quite the same except that instead of breaking the network connection, FileZilla instantly freezes the whole OS when uploading the file for the 6th time and afterwards. There isn't even a bluescreen, and no way to recover except for the reset button on my PC. The server is installed on the same hardware as 7. I had Windows XP installed on it before, and there were no issues with FileZilla.

I had an older version of FileZilla (can't remember which one) installed on Windows 7 before updating to 3.3.0.1, it showed the same behaviour. After updating, it did 5 successful transfers and then re-entered this permanent error state.

It might be a driver problem, but I see no reason why the transfer would succeed the first 5 times and fail afterwards - there has to be some FileZilla-specific problem behind it. Also, there are no problems with the Windows Explorer FTP feature.

Change History (1)

comment:1 by Tim Kosse, 10 years ago

Resolution: rejected
Status: newclosed

A normal program cannot possibly interrupt a networking connection. At most it can trigger an already existing fault condition. FileZilla is no exception to this. There's something wrong with your networking environment and FileZilla merely happens to be the one program triggering the fault.

Note: See TracTickets for help on using tickets.