Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4995 closed Bug report (rejected)

When locale set to TR, file and folder list becomes garbled

Reported by: Volkan Kurt Owned by:
Priority: high Component: FileZilla Client
Keywords: date parsing, locale Cc:
Component version: Operating system type: Other
Operating system version: Solaris 9

Description

Hello,

This is an issue which seems to be previously solved, but I believe it re-appeared at version 3. (The previous ticket #: 4052)

On Solaris 9, when the locale settings are as follows (in /etc/default/init)

LC_COLLATE=tr_TR.UTF-8
LC_CTYPE=tr_TR.UTF-8
LC_MESSAGES=C
LC_MONETARY=tr_TR.UTF-8
LC_NUMERIC=tr_TR.UTF-8
LC_TIME=tr_TR.UTF-8

the folder list is incorrectly parsed and the filenames shows like this:

Kas 16 13:47 .bash_history
Eki 23 2008 .profile

(This part is the datetime part: Kas 16 13:47)

Change History (3)

comment:1 Changed 10 years ago by Volkan Kurt

Here are the client details:

FileZilla Client
----------------

Version:          3.3.0.1

Build information:
  Compiled for:   i586-pc-mingw32msvc
  Compiled on:    x86_64-unknown-linux-gnu
  Build date:     2009-11-15
  Compiled with:  i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
  Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:
  wxWidgets:      2.8.10
  GnuTLS:         2.8.3

I also tried the nightly build, for no avail.

comment:2 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Localized directory listings for FTP servers are a bad idea, it commonly makes those listings unparseable by FTP clients.

Please make sure the server process is started with an international English locale or upgrade to a server that doesn't send localized listings. Preferably upgrade to a server supporting MLSD as that extension avoids the problem altogether.

comment:3 Changed 10 years ago by Volkan Kurt

Sorry, I didn't mention before, the server is SFTP. When I try to send MLSD raw command, filezilla complains:

Trace: CFileZillaEnginePrivate::ResetOperation(4098)
Error: Command not supported by this protocol

So apparently, MLSD is not available with SFTP. I'll try and change the locale.

Thanks.

Note: See TracTickets for help on using tickets.