Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4921 closed Bug report (duplicate)

Download resume bug

Reported by: kidli Owned by:
Priority: high Component: FileZilla Client
Keywords: download resume 3.2.8.1 Cc:
Component version: Operating system type: Linux
Operating system version: Ubuntu 9.04

Description

I set "downloads: resume file transfer" option at file exist action, but it dosent resume but skip all exist file.

Here is a sample log:
10:10:02 Status: Connecting to 192.168.6.201:21...
10:10:02 Status: Connection established, waiting for welcome message...
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 220-FileZilla Server version 0.9.29 beta
10:10:02 Response: 220-written by Tim Kosse (Tim.Kosse@…)
10:10:02 Response: 220 Please visit http://sourceforge.net/projects/filezilla/
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Command: USER poc
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 331 Password required for poc
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Command: PASS
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 230 Logged on
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Command: SYST
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 215 UNIX emulated by FileZilla
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Command: FEAT
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 211-Features:
10:10:02 Response: MDTM
10:10:02 Response: REST STREAM
10:10:02 Response: SIZE
10:10:02 Response: MLST type*;size*;modify*;
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: MLSD
10:10:02 Response: UTF8
10:10:02 Response: CLNT
10:10:02 Response: MFMT
10:10:02 Response: 211 End
10:10:02 Status: Connected
10:10:02 Trace: CFtpControlSocket::ResetOperation(0)
10:10:02 Trace: CControlSocket::ResetOperation(0)
10:10:02 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:02 Status: Retrieving directory listing...
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Trace: CFtpControlSocket::ChangeDirSend()
10:10:02 Command: PWD
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 257 "/" is current directory.
10:10:02 Trace: CFtpControlSocket::ResetOperation(0)
10:10:02 Trace: CControlSocket::ResetOperation(0)
10:10:02 Trace: CFtpControlSocket::ParseSubcommandResult(0)
10:10:02 Trace: CFtpControlSocket::ListSubcommandResult()
10:10:02 Trace: state = 1
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Trace: CFtpControlSocket::TransferSend()
10:10:02 Trace: state = 1
10:10:02 Command: TYPE I
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 200 Type set to I
10:10:02 Trace: CFtpControlSocket::TransferParseResponse()
10:10:02 Trace: code = 2
10:10:02 Trace: state = 1
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Trace: CFtpControlSocket::TransferSend()
10:10:02 Trace: state = 2
10:10:02 Command: PASV
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 227 Entering Passive Mode (192,168,6,201,4,26)
10:10:02 Trace: CFtpControlSocket::TransferParseResponse()
10:10:02 Trace: code = 2
10:10:02 Trace: state = 2
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Trace: CFtpControlSocket::TransferSend()
10:10:02 Trace: state = 4
10:10:02 Command: MLSD
10:10:02 Trace: CTransferSocket::OnConnect
10:10:02 Trace: CFtpControlSocket::OnReceive()
10:10:02 Response: 150 Connection accepted
10:10:02 Trace: CFtpControlSocket::TransferParseResponse()
10:10:02 Trace: code = 1
10:10:02 Trace: state = 4
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Trace: CFtpControlSocket::TransferSend()
10:10:02 Trace: state = 5
10:10:02 Response: 226 Transfer OK
10:10:02 Trace: CFtpControlSocket::TransferParseResponse()
10:10:02 Trace: code = 2
10:10:02 Trace: state = 5
10:10:02 Trace: CFtpControlSocket::SendNextCommand()
10:10:02 Trace: CFtpControlSocket::TransferSend()
10:10:02 Trace: state = 8
10:10:02 Trace: CTransferSocket::OnReceive(), m_transferMode=0
10:10:02 Listing: type=file;modify=20090803122151;size=16138137; IMSClient_.exe
10:10:02 Trace: CTransferSocket::TransferEnd(1)
10:10:02 Trace: CFtpControlSocket::TransferEnd()
10:10:02 Trace: CFtpControlSocket::ResetOperation(0)
10:10:02 Trace: CControlSocket::ResetOperation(0)
10:10:02 Trace: CFtpControlSocket::ParseSubcommandResult(0)
10:10:02 Trace: CFtpControlSocket::ListSubcommandResult()
10:10:02 Trace: state = 3
10:10:02 Trace: CFtpControlSocket::ResetOperation(0)
10:10:02 Trace: CControlSocket::ResetOperation(0)
10:10:02 Status: Directory listing successful
10:10:02 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:05 Status: Connecting to 192.168.6.201:21...
10:10:05 Status: Connection established, waiting for welcome message...
10:10:05 Trace: CFtpControlSocket::OnReceive()
10:10:05 Response: 220-FileZilla Server version 0.9.29 beta
10:10:05 Response: 220-written by Tim Kosse (Tim.Kosse@…)
10:10:05 Response: 220 Please visit http://sourceforge.net/projects/filezilla/
10:10:05 Trace: CFtpControlSocket::SendNextCommand()
10:10:05 Command: USER poc
10:10:05 Trace: CFtpControlSocket::OnReceive()
10:10:05 Response: 331 Password required for poc
10:10:05 Trace: CFtpControlSocket::SendNextCommand()
10:10:05 Command: PASS

10:10:05 Trace: CFtpControlSocket::OnReceive()
10:10:05 Response: 230 Logged on
10:10:05 Status: Connected
10:10:05 Trace: CFtpControlSocket::ResetOperation(0)
10:10:05 Trace: CControlSocket::ResetOperation(0)
10:10:05 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:05 Trace: CFtpControlSocket::FileTransfer()
10:10:05 Status: Starting download of /IMSClient_.exe
10:10:05 Trace: CFtpControlSocket::SendNextCommand()
10:10:05 Trace: CFtpControlSocket::ChangeDirSend()
10:10:06 Command: CWD /
10:10:06 Trace: CFtpControlSocket::OnReceive()
10:10:06 Response: 250 CWD successful. "/" is current directory.
10:10:06 Trace: CFtpControlSocket::SendNextCommand()
10:10:06 Trace: CFtpControlSocket::ChangeDirSend()
10:10:06 Command: PWD
10:10:06 Trace: CFtpControlSocket::OnReceive()
10:10:06 Response: 257 "/" is current directory.
10:10:06 Trace: CFtpControlSocket::ResetOperation(0)
10:10:06 Trace: CControlSocket::ResetOperation(0)
10:10:06 Trace: CFtpControlSocket::ParseSubcommandResult(0)
10:10:06 Trace: FileTransferSubcommandResult()
10:10:06 Trace: CFtpControlSocket::SendNextCommand()
10:10:06 Trace: FileTransferSend()
10:10:06 Trace: CFtpControlSocket::SendNextCommand()
10:10:06 Trace: CFtpControlSocket::TransferSend()
10:10:06 Trace: state = 1
10:10:06 Command: TYPE I
10:10:06 Trace: CFtpControlSocket::OnReceive()
10:10:06 Response: 200 Type set to I
10:10:06 Trace: CFtpControlSocket::TransferParseResponse()
10:10:06 Trace: code = 2
10:10:06 Trace: state = 1
10:10:06 Trace: CFtpControlSocket::SendNextCommand()
10:10:06 Trace: CFtpControlSocket::TransferSend()
10:10:06 Trace: state = 2
10:10:06 Command: PASV
10:10:06 Trace: CFtpControlSocket::OnReceive()
10:10:06 Response: 227 Entering Passive Mode (192,168,6,201,4,27)
10:10:06 Trace: CFtpControlSocket::TransferParseResponse()
10:10:06 Trace: code = 2
10:10:06 Trace: state = 2
10:10:06 Trace: CFtpControlSocket::SendNextCommand()
10:10:06 Trace: CFtpControlSocket::TransferSend()
10:10:06 Trace: state = 4
10:10:06 Command: RETR IMSClient_.exe
10:10:06 Trace: CTransferSocket::OnConnect
10:10:06 Trace: CFtpControlSocket::OnReceive()
10:10:06 Response: 150 Connection accepted
10:10:06 Trace: CFtpControlSocket::TransferParseResponse()
10:10:06 Trace: code = 1
10:10:06 Trace: state = 4
10:10:06 Trace: CFtpControlSocket::SendNextCommand()
10:10:06 Trace: CFtpControlSocket::TransferSend()
10:10:06 Trace: state = 5
10:10:06 Trace: CTransferSocket::OnReceive(), m_transferMode=2
...
10:10:06 Trace: CTransferSocket::OnReceive(), m_transferMode=2
10:10:06 Trace: CFtpControlSocket::ResetOperation(10)
10:10:06 Trace: CControlSocket::ResetOperation(10)
10:10:06 Trace: CFtpControlSocket::ResetOperation(10)
10:10:06 Trace: CControlSocket::ResetOperation(10)
10:10:06 Error: Transfer aborted by user
10:10:06 Trace: CFileZillaEnginePrivate::ResetOperation(10)
10:10:06 Trace: CFtpControlSocket::OnReceive()
10:10:06 Response: 426 Connection closed; transfer aborted.
10:10:06 Trace: Skipping reply after cancelled operation or keepalive command.
10:10:14 Status: Retrieving directory listing...
10:10:14 Trace: CFtpControlSocket::ParseSubcommandResult(0)
10:10:14 Trace: CFtpControlSocket::ListSubcommandResult()
10:10:14 Trace: state = 1
10:10:14 Trace: CFtpControlSocket::SendNextCommand()
10:10:14 Trace: CFtpControlSocket::TransferSend()
10:10:14 Trace: state = 2
10:10:14 Command: PASV
10:10:14 Trace: CFtpControlSocket::OnReceive()
10:10:14 Response: 227 Entering Passive Mode (192,168,6,201,4,28)
10:10:14 Trace: CFtpControlSocket::TransferParseResponse()
10:10:14 Trace: code = 2
10:10:14 Trace: state = 2
10:10:14 Trace: CFtpControlSocket::SendNextCommand()
10:10:14 Trace: CFtpControlSocket::TransferSend()
10:10:14 Trace: state = 4
10:10:14 Command: MLSD
10:10:14 Trace: CTransferSocket::OnConnect
10:10:14 Trace: CFtpControlSocket::OnReceive()
10:10:14 Response: 150 Connection accepted
10:10:14 Trace: CFtpControlSocket::TransferParseResponse()
10:10:14 Trace: code = 1
10:10:14 Trace: state = 4
10:10:14 Trace: CFtpControlSocket::SendNextCommand()
10:10:14 Trace: CFtpControlSocket::TransferSend()
10:10:14 Trace: state = 5
10:10:14 Response: 226 Transfer OK
10:10:14 Trace: CFtpControlSocket::TransferParseResponse()
10:10:14 Trace: code = 2
10:10:14 Trace: state = 5
10:10:14 Trace: CFtpControlSocket::SendNextCommand()
10:10:14 Trace: CFtpControlSocket::TransferSend()
10:10:14 Trace: state = 8
10:10:14 Trace: CTransferSocket::OnReceive(), m_transferMode=0
10:10:14 Listing: type=file;modify=20090803122151;size=16138137; IMSClient_.exe
10:10:14 Trace: CTransferSocket::TransferEnd(1)
10:10:14 Trace: CFtpControlSocket::TransferEnd()
10:10:14 Trace: CFtpControlSocket::ResetOperation(0)
10:10:14 Trace: CControlSocket::ResetOperation(0)
10:10:14 Trace: CFtpControlSocket::ParseSubcommandResult(0)
10:10:14 Trace: CFtpControlSocket::ListSubcommandResult()
10:10:14 Trace: state = 3
10:10:14 Trace: CFtpControlSocket::ResetOperation(0)
10:10:14 Trace: CControlSocket::ResetOperation(0)
10:10:14 Status: Directory listing successful
10:10:14 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:18 Trace: CFtpControlSocket::FileTransfer()
10:10:18 Status: Starting download of /IMSClient_.exe
10:10:18 Trace: CFtpControlSocket::ParseSubcommandResult(0)
10:10:18 Trace: FileTransferSubcommandResult()
10:10:18 Status: Skipping download of /IMSClient_.exe
10:10:18 Trace: CFtpControlSocket::ResetOperation(0)
10:10:18 Trace: CControlSocket::ResetOperation(0)
10:10:18 Status: File transfer successful
10:10:18 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:18 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:25 Trace: CFtpControlSocket::FileTransfer()
10:10:25 Status: Starting download of /IMSClient_.exe
10:10:25 Trace: CFtpControlSocket::ParseSubcommandResult(0)
10:10:25 Trace: FileTransferSubcommandResult()
10:10:25 Status: Skipping download of /IMSClient_.exe
10:10:25 Trace: CFtpControlSocket::ResetOperation(0)
10:10:25 Trace: CControlSocket::ResetOperation(0)
10:10:25 Status: File transfer successful
10:10:25 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:33 Status: Disconnected from server
10:10:33 Trace: CControlSocket::DoClose(64)
10:10:33 Trace: CFtpControlSocket::ResetOperation(66)
10:10:33 Trace: CControlSocket::ResetOperation(66)
10:10:33 Trace: CFileZillaEnginePrivate::ResetOperation(66)
10:10:33 Trace: CControlSocket::DoClose(64)
10:10:33 Trace: CControlSocket::DoClose(64)
10:10:33 Trace: CFileZillaEnginePrivate::ResetOperation(0)
10:10:55 Status: Sending keep-alive command
10:10:55 Command: NOOP
10:10:55 Response: 200 OK
10:11:25 Status: Disconnected from server

Change History (1)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #4891

Note: See TracTickets for help on using tickets.