Opened 10 years ago

Closed 10 years ago

#4906 closed Bug report (duplicate)

Default file action of overwrite if size/date different results in rename

Reported by: Kerry Owned by:
Priority: normal Component: FileZilla Client
Keywords: overwrite, rename, settings Cc:
Component version: Operating system type: Windows
Operating system version: Winfows XP Pro

Description

From menu: transfer -> default file exists action.
In uploads drop down select "Overwrite file if size differs or file is newer". Note that while I was documenting this problem I also discovered that the same thing happens when the default file action exists setting for upload is set for overwrite if different size or newer.

Upload file which does not meet this criteria. A dialog box occurs which asks to rename the file instead of skipping it.

Unfortunately the attached log does not show the fact of the rename dialog appearing and it being cancelled as it only shows that the file is being skipped. In fact the files being uploaded is the second time for them and should have been automatically skipped.

The attached log shows every file as being skipped but in fact the rename dialog was cancelled. Note that I aslso edited the log to remove server name/ip and user information

FZ version:
FileZilla Client


Version: 3.2.8.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2009-10-10
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.10
GnuTLS: 2.8.3

Attachments (1)

Fz-Overwrite bug.txt (10.3 KB) - added by Kerry 10 years ago.
Log file taken when bug action occurring

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by Kerry

Attachment: Fz-Overwrite bug.txt added

Log file taken when bug action occurring

comment:1 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #4891

Note: See TracTickets for help on using tickets.