Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4797 closed Feature request (rejected)

Request: Revision to File Name Sorting

Reported by: 64Pacific Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: xp sp2

Description

Hello:

I noticed a small issue with the way FileZilla lists files in the directory tree. The easiest way to show what I mean is an example, I have shown just a few file names, hopefully enough to establish a pattern.

What I see in the current version:

tcp1.jpg
tcp10.jpg
tcp100.jpg
tcp101.jpg
tcp102.jpg
...
tcp109.jpg
tcp11.jpg
tcp110.jpg
tcp111.jpg
...
tcp119.jpg
tcp12.jpg
tcp120.jpg
tcp121.jpg
... and so on until the end of time

I was thinking the files should be organized like this:

tcp1.jpg
tcp2.jpg
...
tcp9.jpg
tcp10.jpg
tcp11.jpg
tcp12.jpg
...
tcp99.jpg
tcp100.jpg
tcp101.jpg
... and so on until the end of time.

They don't seem to be sequentially ordered based on the whole file name, rather they seem to be ordered by each character, if that makes any sense.

  1. McKenzie

Change History (3)

comment:1 Changed 10 years ago by 64Pacific

Operating system type: Windows
Operating system version: xp sp2

comment:2 Changed 10 years ago by Tim Kosse

Component: UnknownFileZilla Client
Resolution: rejected
Status: newclosed

Thanks for not using the search function. This report is a duplicate of #2978

comment:3 Changed 10 years ago by 64Pacific

I did use the search function, however, I did not receive any results pertaining to the issue. Oh and watch your comments; it has come across as very abrasive.

Note: See TracTickets for help on using tickets.