Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4786 closed Bug report (rejected)

filezilla chunks a few bytes with certain files/hosts

Reported by: bviktor Owned by:
Priority: high Component: FileZilla Client
Keywords: ftp upload txt chunk error Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 RC Ultimate x64 EN

Description

this is really strange. when i upload files via ftp (sftp doesn't seem to be affected), they get smaller on the server after upload. but this doesn't happen with all types and on all hosts. i've made a few tests:

chunks:

  • txt
  • html
  • (no extension)

doesn't chunk:

  • ctt
  • exe
  • ods
  • rar
  • log
  • conf

i couldn't find other file types which trigger this error. version 3.2.7.1. it fails on extra.hu, bplaced.net and godaddy free hosting but it doesn't on sf.net's ftp service.

i've tried to find out where the bug originates from.
3.0.1: fails with html and txt, doesn't with extensionless
3.0.2: fails with all 3
and since that version, the same result with the few releases i've tried.

i can give you an ftp account to one of the failing hosts in case you need it.

the really strange thing is that if i upload a txt, it displays as a smaller file than the one on my pc. if i then download it via http, or download via ftp with total commander, it really downloads a smaller and different file. BUT if i download the 'smaller' file via ftp using filezilla, it downloads the original bigger file (shasum matches).

if i upload files with total commander, the size is correct and it downloads the same file in all three ways (ftp@filezilla, ftp@totalcmd, http).

any ideas?

Change History (2)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

comment:2 Changed 10 years ago by bviktor

the fact that it works ok in totalcmd makes me feel that something's wrong with line ending detection in filezilla, don't you think?

Note: See TracTickets for help on using tickets.