Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4714 closed Bug report (rejected)

FileZilla 3.2.7-rc1: user interface does not react on timeouts

Reported by: JanRei Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP SP3

Description

After the server issued a timeout FileZilla disconnects according to the message log. However, the state of the options available in the toolbar and menus do not change.

In case you need more details, here is the log:
18:25:00 Status: Resolving address of jansspielwiese.pytalhost.de
18:25:00 Status: Connecting to 94.125.71.78:21...
18:25:00 Status: Connection established, waiting for welcome message...
18:25:00 Trace: CFtpControlSocket::OnReceive()
18:25:00 Response: 220 pytalFTP
18:25:00 Trace: CFtpControlSocket::SendNextCommand()
18:25:00 Command: USER phost68566
18:25:00 Trace: CFtpControlSocket::OnReceive()
18:25:00 Response: 331 Password required for phost68566
18:25:00 Trace: CFtpControlSocket::SendNextCommand()
18:25:00 Command: PASS *
18:25:02 Trace: CFtpControlSocket::OnReceive()
18:25:02 Response: 230 User phost68566 logged in
18:25:02 Trace: CFtpControlSocket::SendNextCommand()
18:25:02 Command: SYST
18:25:02 Trace: CFtpControlSocket::OnReceive()
18:25:02 Response: 215 UNIX Type: L8
18:25:02 Trace: CFtpControlSocket::SendNextCommand()
18:25:02 Command: FEAT
18:25:02 Trace: CFtpControlSocket::OnReceive()
18:25:02 Response: 211-Features:
18:25:02 Response: LANG en
18:25:02 Response: MDTM
18:25:02 Response: UTF8
18:25:02 Response: AUTH TLS
18:25:02 Response: PBSZ
18:25:02 Response: PROT
18:25:02 Response: REST STREAM
18:25:02 Response: SIZE
18:25:02 Trace: CFtpControlSocket::OnReceive()
18:25:02 Response: 211 End
18:25:02 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Command: OPTS UTF8 ON
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 200 UTF8 set to on
18:25:03 Status: Connected
18:25:03 Trace: CFtpControlSocket::ResetOperation(0)
18:25:03 Trace: CControlSocket::ResetOperation(0)
18:25:03 Status: Retrieving directory listing...
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::ChangeDirSend()
18:25:03 Command: PWD
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 257 "/" is the current directory
18:25:03 Trace: CFtpControlSocket::ResetOperation(0)
18:25:03 Trace: CControlSocket::ResetOperation(0)
18:25:03 Trace: CFtpControlSocket::ParseSubcommandResult(0)
18:25:03 Trace: CFtpControlSocket::ListSubcommandResult()
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::TransferSend()
18:25:03 Command: TYPE I
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 200 Type set to I
18:25:03 Trace: CFtpControlSocket::TransferParseResponse()
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::TransferSend()
18:25:03 Command: PASV
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 227 Entering Passive Mode (94,125,71,78,146,68).
18:25:03 Trace: CFtpControlSocket::TransferParseResponse()
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::TransferSend()
18:25:03 Command: LIST
18:25:03 Trace: CTransferSocket::OnConnect
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 150 Opening ASCII mode data connection for file list
18:25:03 Trace: CFtpControlSocket::TransferParseResponse()
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::TransferSend()
18:25:03 Trace: CTransferSocket::TransferEnd(1)
18:25:03 Trace: CFtpControlSocket::TransferEnd()
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 226 Transfer complete
18:25:03 Trace: CFtpControlSocket::TransferParseResponse()
18:25:03 Trace: CFtpControlSocket::ResetOperation(0)
18:25:03 Trace: CControlSocket::ResetOperation(0)
18:25:03 Trace: CFtpControlSocket::ParseSubcommandResult(0)
18:25:03 Trace: CFtpControlSocket::ListSubcommandResult()
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::TransferSend()
18:25:03 Command: PASV
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 227 Entering Passive Mode (94,125,71,78,148,159).
18:25:03 Trace: CFtpControlSocket::TransferParseResponse()
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::TransferSend()
18:25:03 Command: LIST -a
18:25:03 Trace: CTransferSocket::OnConnect
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 150 Opening ASCII mode data connection for file list
18:25:03 Trace: CFtpControlSocket::TransferParseResponse()
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::TransferSend()
18:25:03 Trace: CTransferSocket::TransferEnd(1)
18:25:03 Trace: CFtpControlSocket::TransferEnd()
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 226 Transfer complete
18:25:03 Trace: CFtpControlSocket::TransferParseResponse()
18:25:03 Trace: CFtpControlSocket::ResetOperation(0)
18:25:03 Trace: CControlSocket::ResetOperation(0)
18:25:03 Trace: CFtpControlSocket::ParseSubcommandResult(0)
18:25:03 Trace: CFtpControlSocket::ListSubcommandResult()
18:25:03 Trace: Server seems to support LIST -a
18:25:03 Trace: CFtpControlSocket::SendNextCommand()
18:25:03 Trace: CFtpControlSocket::ListSend()
18:25:03 Status: Calculating timezone offset of server...
18:25:03 Command: MDTM phpinfo.php
18:25:03 Trace: CFtpControlSocket::OnReceive()
18:25:03 Response: 213 20090630190334
18:25:03 Trace: CFtpControlSocket::ListParseResponse()
18:25:03 Status: Timezone offsets: Server: 7200 seconds. Local: 7200 seconds. Difference: 0 seconds.
18:25:03 Trace: CFtpControlSocket::ResetOperation(0)
18:25:03 Trace: CControlSocket::ResetOperation(0)
18:25:03 Status: Directory listing successful
18:30:03 Trace: CFtpControlSocket::OnReceive()
18:30:03 Response: 421 Idle timeout (300 seconds): closing control connection
18:30:03 Trace: Unexpected reply, no reply was pending.
18:30:03 Trace: CRealControlSocket::OnClose(0)
18:30:03 Error: Connection closed by server
18:30:03 Trace: CFtpControlSocket::ResetOperation(66)
18:30:03 Trace: CControlSocket::ResetOperation(66)

Change History (2)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is by design. FileZilla automatically reconnects as soon as you try to perform any action.

comment:2 Changed 10 years ago by JanRei

You're right, I got confused. Sorry.

Note: See TracTickets for help on using tickets.