Opened 11 years ago

Closed 11 years ago

Last modified 6 years ago

#4667 closed Bug report (rejected)

Copying files within FTP server moves files instead (via RNTO)

Reported by: chw Owned by:
Priority: normal Component: FileZilla Client
Keywords: file copy client RNTO Cc:
Component version: Operating system type: Windows
Operating system version: XP

Description

Steps to reproduce:
1) log into an FTP server where you have at least two directories (say, A and B)
2) In the server pane (top right), open folder A so that all files in that folder appear in the bottom right pane
3) Drag a file from the bottom right pane to the B folder in the top right pane. Note that the mouse pointer shows we are in copy mode (plus sign).

Expected result:
File is copied from folder A to folder B

Actual result:
Files is moved (RNTO) from folder A to folder B

Change History (2)

comment:1 by Tim Kosse, 11 years ago

Resolution: rejected
Status: newclosed

The FTP protocol does not allow file copy.

Due to technical limitations in the Windows API it is impossible to get a correct drop indication next to the mouse pointer in all situations.

comment:2 by Alexander Schuch, 6 years ago

See #8966 for a very related issue.

Note: See TracTickets for help on using tickets.