Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4647 closed Bug report (fixed)

Synchronized browsing doesn't work while uploading

Reported by: Martin_2 Owned by: Tim Kosse
Priority: normal Component: FileZilla Client
Keywords: Synchronized browsing Cc: filezilla@…
Component version: Operating system type: Windows
Operating system version: Vista

Description

If synchronized browsing is active and a folder contains a lot of small files (>100) the following behaviour was observed:
Some files where selected and uploaded. While uploading is in progress, the folder is changed to another folder with a lot of small files (>100) on the local side. The folder is then not changed on the server side while the upload is in progress. Another folder must be selected after upload is finished to synchronize the folder view again. This happens in version 3.2.6.1 and before.

Change History (6)

comment:1 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

What exactly do you mean? What should have happened instead?

Please give step by step instruction how to reproduce this problem as detailed as possible, you cannot be too verbose.

comment:2 Changed 10 years ago by Martin_2

Status: moreinfonew

In Version 3.2.7.1 the behaviour seems to be exactly the opposite: the server side is changed and the local side remains in the old view. Here is a step by step instruction:

  1. Connect to a webspace where synchronized browsing has been enabled and is active after connecting
  2. Click on a subfolder on the local side (the hard drive) which also exists on the server side which contains a lot of files (>1000) which have a size about 30 KB or smaller. I don't think this is important, in my case, these are pictures and HTMLs
  3. Upload let's say 20 files and while uploading, select another folder which also contains a lot of files (>1000), in this case HTMLs with about 0,5 KB in size, on the local side
  4. The view is updated to this folder only on the server side.

I could reproduce the behaviour several times but not always, especially not the second time when I select a folder because the caching works fine. FileZilla has to be restarted for every test. After a few tries the behaviour was not reproducible anymore, perhaps because of caching.

I hope this will help.

comment:3 Changed 10 years ago by Tim Kosse

After a few tries the behaviour was not reproducible anymore, perhaps because of caching.

All caches are dropped if you exit FileZilla.

comment:4 Changed 10 years ago by Tim Kosse

Owner: set to Tim Kosse
Status: newaccepted

I just managed to reproduce it.

comment:5 Changed 10 years ago by Tim Kosse

Resolution: fixed
Status: acceptedclosed

Should be fixed.

Please try the upcoming 2009-10-02 build from http://filezilla-project.org/nightly.php

comment:6 Changed 10 years ago by Martin_2

In a short test, it seems to works now. Thanks a lot!

Note: See TracTickets for help on using tickets.