Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#4626 closed Bug report (duplicate)

Data connection SSL warning: SSL3 alert write: fatal: bad record mac

Reported by: jeremy Owned by:
Priority: blocker Component: FileZilla Client
Keywords: bad record mac, gnutls Cc: v2px
Component version: Operating system type: Windows
Operating system version: Windows XP sp3

Description

Only Client 3.2.6 corrupts files during upload/transfer. Downloading files works just fine. During upload of files to filezilla server 0.9.27 and filezilla server 0.9.32 both of which are set up with ftps port 990 using passive transfer mode, files stop and restart at random offsets thusly corrupting the files. also strange is if you click disconnect from ftp server during a transfer, the files continue to transfer. The only way to stop it is to completely close filezilla client. Error received during corruption is "Data connection SSL warning: SSL3 alert write: fatal: bad record mac". logged as follows...(names and ip addresses changed)

(000039) 6/30/2009 15:44:50 PM - (not logged in) (XX.XXX.XXX.XXX)> SSL connection established
(000039) 6/30/2009 15:44:51 PM - (not logged in) (XX.XXX.XXX.XXX)> USER FTPUSER
(000039) 6/30/2009 15:44:51 PM - (not logged in) (XX.XXX.XXX.XXX)> 331 Password required for FTPUSER
(000039) 6/30/2009 15:44:51 PM - (not logged in) (XX.XXX.XXX.XXX)> PASS
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> 230 Logged on
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> PBSZ 0
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> 200 PBSZ=0
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> PROT P
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> 200 Protection level set to P
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> CWD /1ST QUARTER
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> 250 CWD successful. "/1ST QUARTER" is current directory.
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> TYPE I
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> 200 Type set to I
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> PASV
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> 227 Entering Passive Mode (XX,XX,XXX,XXX,195,83)
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> APPE Cable 2 X3e.pdf
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> 150 Connection accepted, restarting at offset 3063808
(000039) 6/30/2009 15:44:51 PM - FTPUSER (XX.XXX.XXX.XXX)> SSL connection for data connection established
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> Data connection SSL warning: SSL3 alert write: fatal: bad record mac
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> 426 Connection closed; transfer aborted.
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> PASV
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> 227 Entering Passive Mode (XX,XX,XXX,XXX,195,84)
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> MLSD
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> 150 Connection accepted
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> SSL connection for data connection established
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> 226 Transfer OK
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> PASV
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> 227 Entering Passive Mode (XX,XX,XXX,XXX,195,85)
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> APPE Cable 2 X3e.pdf
(000039) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> 150 Connection accepted, restarting at offset 3211264
(000040) 6/30/2009 15:44:52 PM - FTPUSER (XX.XXX.XXX.XXX)> Data connection SSL warning: SSL3 alert write: fatal: bad record mac
(000040) 6/30/2009 15:44:53 PM - FTPUSER (XX.XXX.XXX.XXX)> 426 Connection closed; transfer aborted.

Change History (5)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Please use the search function. Duplicate of #4617 and #4623

comment:2 Changed 10 years ago by jeremy

Priority: highcritical

Similar issue and settings but different error. As long as this error string is in the bug list at least people know its a known issue, since the other two tickets do NOT include the same error message.

Data connection SSL warning: SSL3 alert write: fatal: bad record mac

Thanks,
Jeremy

comment:3 Changed 10 years ago by Tim Kosse

Priority: criticalblocker

Fixed in 3.2.6.1, caused by a bug in GnuTLS 2.8.x

I've posted a write-up at http://forum.filezilla-project.org/viewtopic.php?p=46325#p46325

comment:4 Changed 10 years ago by v2px

Cc: v2px added
Keywords: bad record mac gnutls added
Operating system type: WindowsLinux
Operating system version: Windows XP sp32.6.30-gentoo-r1 / Gentoo GNU/Linux
Priority: blockerhigh
Resolution: duplicate
Status: closedreopened

Reopened because not fixed on Linux versions.
I used FileZilla 3.2.6.1 with GnuTLS 2.8.1 on Gentoo GNU/Linux and uploads still failed with the "bad record mac" error.
Downgrading GnuTLS to 2.6.6 fixed the Problem for now but FileZilla seems to be the only app with this problem.
I'll post a bug report to the Gentoo bugtracker too. And maybe the GnuTLS one if i can find it.

Jens

comment:5 Changed 10 years ago by Tim Kosse

Operating system type: LinuxWindows
Operating system version: 2.6.30-gentoo-r1 / Gentoo GNU/LinuxWindows XP sp3
Priority: highblocker
Resolution: duplicate
Status: reopenedclosed

This is still a duplicate of the above mentioned tickets.

And now I need to waste time reverting your ticket changes.

Note: See TracTickets for help on using tickets.