Opened 10 years ago

Closed 7 years ago

Last modified 6 years ago

#4617 closed Bug report (fixed)

Could not write to transfer socket: ECONNABORTED

Reported by: hakan Owned by:
Priority: normal Component: FileZilla Client
Keywords: ECONNABORTED Cc:
Component version: Operating system type: Windows
Operating system version: Vista

Description

After upgrading to 3.2.6 I have a problem with uploading/downloading files using FTPS implicit. With 3.2.4 it is OK.

Kommando: PASV
Svar: 227 Entering Passive Mode (192,168,70,32,195,116).
Kommando: LIST -a

Svar: 150 Opening BINARY mode data connection.
Svar: 226 Transfer complete.
Kommando: PASV
Svar: 227 Entering Passive Mode (192,168,70,32,195,117).
Kommando: STOR Getting_Started
Svar: 150 Opening BINARY mode data connection.
Fel: Could not write to transfer socket: ECONNABORTED - Connection aborted
Svar: 550 The specified data could not be decrypted.

Change History (5)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Known problem, seems to be caused by a bug in GnuTLS.

Please try this special build, contains an experimental patch for GnuTLS: http://filezilla-project.org/nightlies2/2009-06-29/i586-mingw32msvc/FileZilla_3_setup.exe

comment:2 in reply to:  1 Changed 10 years ago by nwong-target

Special build http://filezilla-project.org/nightlies2/2009-07-01/i586-mingw32msvc/FileZilla_3_setup.exe seems to have resolved the error I was receiving (verbose log below).

Trace: GnuTLS alert 20: Bad record MAC
Trace: GnuTLS error -12: A TLS fatal alert has been received.


Test environment:
OS: Windows XP Professional with SP3
FileZilla version: 3.2.6, build date 2009-06-28
Servertype: FTPS - FTP over implicit TLS/SSL
Setup: FTP server (Rhinosoft Serv-U FTP 8.0.0.7) software and FileZilla client are on the same system, so hopefully no problems caused by network devices, routers/firewalls/etc. FileZilla set to overwrite by default (don't prompt user for overwrite).
Action: upload 100mb.txt file to FTP server.


Log:
Status: Resolving address of ###
Status: Connecting to ###.###.###.##:990...
Status: Connection established, initializing TLS...
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: Handshake successful
Trace: Cipher: ARCFOUR-128, MAC: SHA1
Status: Verifying certificate...
Trace: CFtpControlSocket::SendNextCommand()
Status: TLS/SSL connection established, waiting for welcome message...
Trace: CFtpControlSocket::OnReceive()
Response: 220 Welcome to ###
Trace: CFtpControlSocket::SendNextCommand()
Command: USER alta
Trace: CFtpControlSocket::OnReceive()
Response: 331 User name okay, need password.
Trace: CFtpControlSocket::SendNextCommand()
Command: PASS *
Trace: CFtpControlSocket::OnReceive()
Response: 230 User logged in, proceed.
Trace: CFtpControlSocket::SendNextCommand()
Command: PBSZ 0
Trace: CFtpControlSocket::OnReceive()
Response: 200 PBSZ command OK. Protection buffer size set to 0.
Trace: CFtpControlSocket::SendNextCommand()
Command: PROT P
Trace: CFtpControlSocket::OnReceive()
Response: 200 PROT command OK. Using private data connection.
Status: Connected
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Status: Retrieving directory listing...
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "/" is current directory.
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Status: Directory listing successful
Status: Disconnected from server
Trace: CFtpControlSocket::ResetOperation(66)
Trace: CControlSocket::ResetOperation(66)
Status: Resolving address of usoc.ftp.targetsite.com
Status: Connecting to ###.###.###.###:990...
Status: Connection established, initializing TLS...
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: Handshake successful
Trace: Cipher: ARCFOUR-128, MAC: SHA1
Status: Verifying certificate...
Trace: CFtpControlSocket::SendNextCommand()
Status: TLS/SSL connection established, waiting for welcome message...
Trace: CFtpControlSocket::OnReceive()
Response: 220 Welcome to ###
Trace: CFtpControlSocket::SendNextCommand()
Command: USER alta
Trace: CFtpControlSocket::OnReceive()
Response: 331 User name okay, need password.
Trace: CFtpControlSocket::SendNextCommand()
Command: PASS
*
Trace: CFtpControlSocket::OnReceive()
Response: 230 User logged in, proceed.
Trace: CFtpControlSocket::SendNextCommand()
Command: PBSZ 0
Trace: CFtpControlSocket::OnReceive()
Response: 200 PBSZ command OK. Protection buffer size set to 0.
Trace: CFtpControlSocket::SendNextCommand()
Command: PROT P
Trace: CFtpControlSocket::OnReceive()
Response: 200 PROT command OK. Using private data connection.
Status: Connected
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::FileTransfer()
Status: Starting upload of C:\file100mb.txt
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: CWD /
Trace: CFtpControlSocket::OnReceive()
Response: 250 Directory changed to /
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: FileTransferSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: FileTransferSend()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE A
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to A.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (###,###,###,###,7,214)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: STOR file100mb.txt
Trace: CFtpControlSocket::OnReceive()
Response: 150 Opening ASCII mode data connection for file100mb.txt.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Trace: CTransferSocket::OnConnect
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: Handshake successful
Trace: Cipher: ARCFOUR-128, MAC: SHA1
Trace: CTransferSocket::OnConnect
Trace: GnuTLS alert 20: Bad record MAC
Trace: GnuTLS error -12: A TLS fatal alert has been received.
Trace: CTransferSocket::OnClose(10053)
Trace: CTransferSocket::TransferEnd(3)
Trace: CFtpControlSocket::TransferEnd()
Trace: CFtpControlSocket::OnReceive()
Response: 226 Transfer complete. 212,992 bytes transferred. 47.37 KB/sec.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CFtpControlSocket::ParseSubcommandResult(2)
Trace: FileTransferSubcommandResult()
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CFtpControlSocket::FileTransfer()
Status: Starting upload of C:\file100mb.txt
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: FileTransferSubcommandResult()
Status: Retrieving directory listing...
Trace: ftpcontrolsocket.cpp(1281): List called from other command caller=0p19ed190
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to I.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (###,###,###,###,7,214)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: LIST
Trace: CFtpControlSocket::OnReceive()
Response: 150 Opening ASCII mode data connection for /bin/ls.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Trace: CTransferSocket::OnConnect
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: Handshake successful
Trace: Cipher: ARCFOUR-128, MAC: SHA1
Trace: CTransferSocket::OnConnect
Trace: CFtpControlSocket::OnReceive()
Response: 226 Transfer complete. 3,687 bytes transferred. 5.76 KB/sec.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Trace: CTlsSocket::OnSocketEvent(): close event received
Trace: CTransferSocket::TransferEnd(1)
Trace: CFtpControlSocket::TransferEnd()
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: FileTransferSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: FileTransferSend()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE A
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to A.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (###,###,###,###,7,214)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: STOR file100mb.txt
Trace: CTransferSocket::OnConnect
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CFtpControlSocket::OnReceive()
Response: 150 Opening ASCII mode data connection for file100mb.txt.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: Handshake successful
Trace: Cipher: ARCFOUR-128, MAC: SHA1
Trace: CTransferSocket::OnConnect
Trace: GnuTLS alert 20: Bad record MAC
Trace: GnuTLS error -12: A TLS fatal alert has been received.
Trace: CTransferSocket::OnClose(10053)
Trace: CTransferSocket::TransferEnd(3)
Trace: CFtpControlSocket::TransferEnd()
Trace: CFtpControlSocket::OnReceive()
Response: 226 Transfer complete. 212,992 bytes transferred. 42.53 KB/sec.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CFtpControlSocket::ParseSubcommandResult(2)
Trace: FileTransferSubcommandResult()
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CFtpControlSocket::FileTransfer()
Status: Starting upload of C:\file100mb.txt
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: FileTransferSubcommandResult()
Status: Retrieving directory listing...
Trace: ftpcontrolsocket.cpp(1281): List called from other command caller=0p19ed190
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to I.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (###,###,###,###,7,214)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: LIST
Trace: CFtpControlSocket::OnReceive()
Response: 150 Opening ASCII mode data connection for /bin/ls.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Trace: CTransferSocket::OnConnect
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: CTlsSocket::Handshake()
Trace: Handshake successful
Trace: Cipher: ARCFOUR-128, MAC: SHA1
Trace: CTransferSocket::OnConnect
Trace: CFtpControlSocket::OnReceive()
Response: 226 Transfer complete. 3,687 bytes transferred. 9.23 KB/sec.

comment:3 Changed 10 years ago by Tim Kosse

Fixed in 3.2.6.1, caused by a bug in GnuTLS 2.8.x

I've posted a write-up at http://forum.filezilla-project.org/viewtopic.php?p=46325#p46325

comment:4 Changed 7 years ago by Alexander Schuch

Resolution: fixed
Status: closedreopened

comment:5 Changed 7 years ago by Alexander Schuch

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.