Opened 11 years ago

Closed 8 years ago

Last modified 7 years ago

#4594 closed Bug report (outdated)

Error with .htaccess

Reported by: skity Owned by:
Priority: normal Component: FileZilla Client
Keywords: .htaccess view Cc:
Component version: Operating system type: Windows
Operating system version: Win7 64 bit

Description

We cannot see the .htaccess on some FTP server.
On the FTP Server of http://www.olympe-network.com/ I see the .htaccess with Adobe Dreamweaver but not with FileZilla.

Attachments (2)

first.png (101.6 KB ) - added by skity 11 years ago.
With FileZilla
second.png (150.1 KB ) - added by skity 11 years ago.
With the other Software

Download all attachments as: .zip

Change History (12)

comment:1 by skity, 11 years ago

This bug appear after explored a folder.

comment:2 by Tim Kosse, 11 years ago

Priority: criticallow
Resolution: rejected
Status: newclosed

Please enable "Show raw directory listings" on the debug page in the settings dialog.

Reopen this ticket if .htaccess appears in the message log.

If it does not appear in the message log your server is broken. Please contact the server administrator in that case.

in reply to:  2 comment:3 by skity, 11 years ago

Resolution: rejected
Status: closedreopened

First: I have correctly checked "view hidden files" in the FileZilla settings.
Second: The server is not broken because I see the .htaccess with an other Software.

comment:4 by skity, 11 years ago

Priority: lowcritical

comment:5 by Tim Kosse, 11 years ago

Priority: criticallow
Resolution: rejected
Status: reopenedclosed

I repeat:

Please enable "Show raw directory listings" on the debug page in the settings dialog.

Reopen this ticket if .htaccess appears in the message log.

If it does not appear in the message log your server is broken. Please contact the server administrator in that case.

by skity, 11 years ago

Attachment: first.png added

With FileZilla

by skity, 11 years ago

Attachment: second.png added

With the other Software

comment:6 by skity, 11 years ago

Priority: lownormal
Resolution: rejected
Status: closedreopened

Sorry I reopen because I'm sure what I tell you.
Now I check the "Show raw directory listings" and there isn't the htaccess but with my other software, there is the htaccess.
Look my screenshoot joined with this ticket.

comment:7 by Tim Kosse, 11 years ago

Resolution: rejected
Status: reopenedclosed

Like I said, a broken server. It does not include .htaccess in standards compliant listings. If you can list it with other software then it is due to the fact that they violate the FTP standard by using non-standard extensions. Contact the server administrator so that he can install a proper server.

comment:8 by Dave, 10 years ago

Operating system version: VistaWin7 64 bit
Resolution: rejected
Status: closedreopened

I've been sweating over this all day, and I believe it IS a bug, at least on my system (win7 64bit):

  • Filezilla 3.3.4.1 runs fine, but does not show .htaccess on two major services - Lunarpages, Hostgator - whether I check Server/'Force settings...' or not.
  • A fresh install of Filezilla 2.2.17 showed .htaccess right away on hostgator, with no need to check View/'show hidden file' or Edit/Settings/Interface settings/Remote file list/'Always show hidden file...'
  • To confirm, I did a raw directory listing in v3, which showed .htaccess, even if it did not display in the window.

Based on this, I am confident that some people are having a bug with this; not everyone, but some, including me. It seems odd that v2 had two hidden file settings, while v3 has only one - could that be the problem? In any case, I'll have to use v2 for now, or permanently, if you decide to close/reject this ticket again.

comment:9 by Alexander Schuch, 8 years ago

Status: reopenedmoreinfo_reopened

Can you please provide a full log with "raw directory listing" enabled?

I try to explain the problem: FileZilla first asks the server which features it supports. I believe (due to you lacking to provide a log) that the server says "I support MLSD" command. FileZilla then issues the MLSD command and your server responds but does not include ".htaccess" file (this can be seen in your screenshot first.png).

As a result, FileZilla does not show this file. It is not a bug of FileZilla client, but a bug in your server.

Now, what other FTP clients do: They do not ask what the server supports, they simply assume the standard from more than 20 years ago. So they use "LIST" command instead of "MLSD". And for some reason, your server there includes ".htaccess" in its answer.

So to conclude, the FTP server you are using violates the FTP standard by not including all files in response to a "MLSD" command request.

comment:10 by Alexander Schuch, 8 years ago

Resolution: outdated
Status: moreinfo_reopenedclosed

No reply for more than 28 days.

Note: See TracTickets for help on using tickets.