Opened 11 years ago

Closed 11 years ago

#4575 closed Bug report (rejected)

Corrupt file list when using foreign signs (öéò etc)

Reported by: Udo Bonjernoor Owned by:
Priority: normal Component: FileZilla Client
Keywords: Corrupt filelist foreign signs Cc:
Component version: Operating system type: Windows
Operating system version: Vista SP1 (Dutch)

Description

Fz seems to have problems with special filenames.
For example, while connecting to a Qnap 639 (a NAS),

See printscreen (attached) for example

FileZilla Client


Version: 3.2.4.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2009-04-27
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Dependencies:

wxWidgets: 2.8.10
GnuTLS: 2.6.4


Attachments (1)

FileZilla.png (91.6 KB) - added by Udo Bonjernoor 11 years ago.
Example of corrupt filelist when using foreign sign

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by Udo Bonjernoor

Attachment: FileZilla.png added

Example of corrupt filelist when using foreign sign

comment:1 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is caused by a broken server that does not follow the FTP specifications by not using UTF-8 as encoding for non-ASCII characters.

You have two choices. Either refrain from using non-ASCII characters or upgrade to a proper server.

Read http://wiki.filezilla-project.org/Character_Set for details.

Contact your NAS box vendor to get support for your particular server.

Note: See TracTickets for help on using tickets.