Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#4537 closed Bug report (fixed)

unintentional move of files by clicking into filezilla

Reported by: Deguto Owned by: Tim Kosse
Priority: high Component: FileZilla Client
Keywords: rename, move file Cc:
Component version: Operating system type: Windows
Operating system version: XP SP2

Description

Filezilla Version 3.2.4.1.
The Bug still remained after updating to 3.2.4.1.
I often have a very bad and nerving problem. I use Filezilla for editing files on the “ftp remote side” (server side). My

default editor is Notepad++ and I use the “widescreen-view” with directory-trees in FileZilla.
Now my problem: I perform a right click on “ftp remote side” on a file and then in the context menu I click 'edit'. The Notepad

opens the file and I do modifications. I save the file and click into the FileZilla-window (on “ftp remote side”) and confirm

the overwrite prompt. And then sometimes this bug appears:
FileZilla moves another file (the one I have clicked onto in order to go back into the FileZilla window) into another directory

of the directory tree. I have not clicked and dragged/moved the file! I have only clicked the file in order to go back to the

FileZilla window and then I confirm the prompt.
I think the bug comes only in a sequence of unfortunate events.

Attachments (3)

FileZilla-Bug1.png (46.9 KB) - added by Deguto 10 years ago.
Step 1
FileZilla-Bug2.png (51.6 KB) - added by Deguto 10 years ago.
Step 2
FileZilla-Bug3.png (45.7 KB) - added by Deguto 10 years ago.
Step 3

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Tim Kosse

Owner: set to Tim Kosse
Status: newaccepted

Confirmed and reproduced.

As workaround simply click the titlebar of FileZilla to get it into focus.

comment:2 Changed 10 years ago by Tim Kosse

Resolution: fixed
Status: acceptedclosed

Will be fixed in the next version.

Please try the upcoming 2009-05-29 build from http://filezilla-project.org/nightly.php

Related bug with similar symptoms: #4328

Changed 10 years ago by Deguto

Attachment: FileZilla-Bug1.png added

Step 1

Changed 10 years ago by Deguto

Attachment: FileZilla-Bug2.png added

Step 2

Changed 10 years ago by Deguto

Attachment: FileZilla-Bug3.png added

Step 3

comment:3 Changed 10 years ago by Deguto

Resolution: fixed
Status: closedreopened

Addendum: Now I know where the problem lies. Once you click on a file to get back into the focus of the FileZilla window, the “prompt” appears and FileZilla presumably recognizes through the “Mouse-Down-Event” the beginning of a “File-Drag/Move-Event”. If you now click the OK Button, FileZilla interprets this as “release of mouse button” and assumes one wants to move the file. The area the mouse cursor is pointing to after clicking OK becomes the target of the “File-Drag/Move-Event”.
One solution for the problem could be through the abortion of a potential “File-Drag/Move-Event” when reaching the “prompt”.
The bug doesn’t appear, when you get back the focus of the FileZilla window for example by
1) clicking on the title bar or
2) by highlighting the FileZilla window pressing Alt+TAB or
3) by clicking on the taskbar.
In my opinion however, this bug should be corrected as it often happens unnoticed. It can cause a lot of damage.

Now I have attached three screenshots.

comment:4 Changed 10 years ago by Deguto

I have installed the nightly version i586-mingw32msvc from 2009-05-21. The problem is there also.

Please, I need the i586-mingw32msvc (.exe) download of the upcoming 2009-05-29 for testing.

comment:5 Changed 10 years ago by Deguto

Resolution: fixed
Status: reopenedclosed

Hi,
I have installed the nightly version i586-mingw32msvc from 2009-05-29.
The Problem is fixed!!! I can't replicate the bug! Thanks.

Note: See TracTickets for help on using tickets.