Opened 11 years ago

Closed 7 years ago

#4223 closed Feature request (duplicate)

add sftp protocol handler sftp://myserver

Reported by: dipe Owned by:
Priority: normal Component: FileZilla Client
Keywords: convenient downlaoding Cc:
Component version: Operating system type: Windows
Operating system version:

Description

WinSCP has a great feature that allows you to put a url into an email like this:
sftp://myserver.mydomain.org/myfile.zip. The recipient clicks on the email and winscp opens the file and prompts you for a download location.
We would very much prefer to use filezilla, but our users are relying on this feature

This is what needs to be added to the Windows registry for Winscp. filezilla should work in a similar fashion.

############################################################
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\SFTP]
@="URL: SFTP Protocol"
"URL Protocol"=""
"EditFlags"=dword:00000002
"BrowserFlags"=dword:00000008

[HKEY_CLASSES_ROOT\SFTP\DefaultIcon]
@="\"C:
Program Files
WinSCP
WinSCP.exe\",0"

[HKEY_CLASSES_ROOT\SFTP\shell]

[HKEY_CLASSES_ROOT\SFTP\shell\open]

[HKEY_CLASSES_ROOT\SFTP\shell\open\command]
@="\"C:
Program Files
WinSCP
WinSCP.exe\" /unsafe \"%1\""

Change History (1)

comment:1 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #2435.

Note: See TracTickets for help on using tickets.