Opened 12 years ago

Closed 11 years ago

Last modified 7 years ago

#4199 closed Bug report (rejected)

Maximum number of connections

Reported by: Aximili Owned by:
Priority: normal Component: FileZilla Client
Keywords: simultaneous connections Cc:
Component version: Operating system type: Linux
Operating system version: XP Pro SP3 (initial report) and Linux (recent SUSE)

Description

You cannot to use FileZilla on www.110mb.com, as it does not allow multiple connections from the same IP.

Going to Site Manager - Transfer Setting - Limit simultaneous connections to 1 <-- does not work.

The only way is to change the global setting (Edit - Settings - Transfers).

Other than that FileZilla is the best, thanks.

Change History (5)

comment:1 by Tim Kosse, 12 years ago

Status: newmoreinfo

Please describe the exact steps necessary to reproduce it on a public server.

comment:2 by Roberto Jimeno, 11 years ago

Operating system type: WindowsLinux
Operating system version: XP Pro SP3XP Pro SP3 (initial report) and Linux (recent SUSE)
Priority: lownormal
Status: moreinfonew

Here some more information:

...
Status: Connection established, waiting for welcome message...
Response: 421 Too many connections (8) from this IP
Error: Could not connect to server
Status: Delaying connection due to previously failed connection attempt...
...

the top area on Filezilla's window. I *DO* have my File -> Site Manager -> Transfer Settings -> Limit number of simutaeous connections --> selected and set to one. In spite of that I still get error 421 for what seem to be 8 connections. I noticed that the problem appeared less frequently than it did before I had it set for "unlimited" connections, but still puzzles me and I believe Filezilla could do better to handle picky servers like the ones provided by Total Choice Hosting LLC.

Please ask questions if you want more information so I can provide it to you.
Thanks.

comment:3 by Tim Kosse, 11 years ago

Resolution: rejected
Status: newclosed

If it still happens if limited to 1 I suspect a broken server. You need to contact your server administrator so that he can get rid of that stupid limit. He might not know it, but a modern server can easily handle thousands of simultaneous connections.

comment:4 by wireblue, 11 years ago

Resolution: rejected
Status: closedreopened

I can verify this bug in FileZilla 3.3.0.1 (Windows XP SP3).

FileZilla does not obey the Max Connection Limit (in Site Manager > Transfer Settings > Limit number of connections...). Servers will block our IP if we transfer too many files in a short period of time. On one occasion FileZilla had opened 830+ connections to the one server, even though the limit was set to 1 or 2 connections.

Removing the FTP server's connection limits is not a valid solution. Limits are in place for a reason, and not all users are in a position to either change the FTP server config or request such changes.

Would appreciate any efforts in resolving this bug.
Thanks, Wireblue.

comment:5 by Tim Kosse, 11 years ago

Resolution: rejected
Status: reopenedclosed

The maximum number of FTP connections that can ever be used by FileZilla at the same time is 10 + 1/tab if no limits are set. It is impossible to get above that.

If you see 830+ open connections on your server there are two possible explanations:

  • Broken router and/or firewall that's silently dropping connection
  • Broken server

In either case, this isn't a bug in FileZilla as it just cannot possibly open this many simultaneous connections.

Note: See TracTickets for help on using tickets.