Opened 10 years ago

Closed 9 years ago

Last modified 5 years ago

#4147 closed Feature request (rejected)

Please add Secure Copy Protocol (SCP) support

Reported by: macrostb Owned by:
Priority: normal Component: FileZilla Client
Keywords: SCP Cc:
Component version: Operating system type:
Operating system version:

Description

Please add Secure Copy Protocol (SCP) support as an option to Filezilla. I noted ticket #2096 but don't care for WinSCP, I just want support for SCP. I appreciate that FileZilla is primarily a client for ftp and it's derivatives, which scp technically isn't, unfortunately however many shells seem to still provide only SCP, not the superior SFTP.

Change History (14)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

The SCP protocol lacks several important features. For starters, you cannot list directories through SCP which is a central requirement for the usability of FileZilla. Try downloading files you cannot select because you cannot see them.

comment:2 Changed 10 years ago by macrostb

Resolution: rejected
Status: closedreopened

I am aware the SC Protocol limitations used in isolation are insufficient, however as I understand the workings of SCP it relies on establishing an initial shell connection, which would permit standard unix ls -l style commands to be sent first; parsing the response in the background would then allow an 'interface layer' to be constructed to feed the necessary additional file and directory list information to FileZilla's normal handler functions to drive the UI. Once files are selected then SCP itself could be used to perform the actual transfers. I believe this is what WinSCP does, at it DOES provide file lists in a GUI view.

comment:3 Changed 9 years ago by Jim Michaels

I agree. filezilla's support for large files is bad. right now I can't upload anything larger than 700MB without a connection being dropped.

it is possible this is my linksys router, all linksys routers drop connections on a regular basis. but I got this quote from my hosting provider.

"For files bigger than 500MB if you're using Windows, we recommend you to use WinSCP, and set it to use SFTP mode with SCP fallback.
Could you try with this email client and let us know? It uses shell access and is far more reliable for big files.
Thanks for using the help desk, if you have any further difficulties or are required to respond to your request, please login to the help desk"

comment:4 Changed 9 years ago by Tim Kosse

For files bigger than 500MB if you're using Windows, we recommend you
to use WinSCP, [...] Could you try with this email client and let us know?

Yes, email client indeed. They are just clueless and are making up excuses.

I agree. filezilla's support for large files is bad. right now I
can't upload anything larger than 700MB without a connection being dropped.

I have no problems uploading files of 10GB and more even over slower connections. If you get disconnects then either your internet connection is highly unstable or your networking equipment is broken.

comment:5 Changed 9 years ago by Jim Michaels

what router are you using to get 10GB file xfers? it's probably not a linksys. I found out a while back that all linksys drop connections.

comment:6 Changed 9 years ago by Jim Michaels

btw, the apple routers do not drop connections, and they work with PC's. you don't need to load the software that comes with them because that's for accessing mac stuff I think.

comment:7 in reply to:  6 Changed 9 years ago by macrostb

The only reason for my asking for SCP support to be added into FileZilla is to provide flexibility with unix shell logins that ONLY support the inferior SCP protocol. I suspect SCP is used partly for historical reasons, but probably because SCP uses the authenticated shell login itself to run a temporary remote process to handle send/receive operations. This also avoids the shell host having to parallel-manage an sftp deamon, which would require duplication of uname/pswd and home directory details for each account, not to mention security updates when needed. It is generally also possible to locally run filezilla-server, then issue ftp commands on the remote shell, however this is not a 'gui' solution, and is far from convenient.

As far as your large file problems are concerned i'm sure the issue is unlikely to be helped by SCP, as FTP/SFTP has provision for restarting downloads from arbitrary positions in the event of a link failure. This feature DOES need to be supported by the remote FTP/SFTP server, but as far as i know SCP offers no improvements that would help with large files.

In the meantime, you could resort to the old split/join tools, if you don't mind command line, and break your transfers into smaller chunks. These are standard on *nix based systems or readily available, and you can obtain a native Win32 port as part of the GnuWin32 project. You'll find what you need in the coreutils package. Installer URL is http://sourceforge.net/projects/gnuwin32/files/coreutils/5.3.0/coreutils-5.3.0.exe/download

Also, have you checked... it's perhaps your ISP that's causing the hiccups, rather than your router. Good luck, either way.

comment:8 Changed 9 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

what router are you using to get 10GB file xfers?

An old computer too slow to work with running Linux. Those are perfect for routing. Best of all, I'm in complete control over the system. Do that with proprietary routers.

This also avoids the shell host having to parallel-manage an sftp deamon, which would require duplication of uname/pswd and home directory details for each account

I'm using OpenSSH and don't need to duplicate anything. You're probably doing it wrong.

Anyhow, as I mentioned before, SCP lacks directory listing capabilities and as such is unsuited for use in FileZilla. You would always need to perform manual transfers. And if you can do those you could just as well use a commandline SCP client. Thus closing this ticket.

comment:9 Changed 9 years ago by Jim Michaels

Resolution: rejected
Status: closedreopened

nonetheless, when I use SCP, my large file transfers get across, even with my flaky router: I just tried winscp (that is the only thing I like about it - I don't like the interface). when I use filezilla FTP, I restart many times and it never gets across. I may try SFTP on filezilla instead of FTP and see if that makes any difference. I hope Filezilla automatically gets keys.

What about using FTP to get the file listings, and use SCP for the file copies? I suppose it could be called FTP+SCP.

comment:10 Changed 9 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

comment:11 in reply to:  8 Changed 9 years ago by macrostb

Replying to codesquid:

This also avoids the shell host having to parallel-manage an sftp deamon, which would require duplication of uname/pswd and home directory details for each account

I'm using OpenSSH and don't need to duplicate anything. You're probably doing it wrong.

Anyhow, as I mentioned before, SCP lacks directory listing capabilities and as such is unsuited for use in FileZilla. You would always need to perform manual transfers. And if you can do those you could just as well use a commandline SCP client. Thus closing this ticket.

Re:'You're probably doing it wrong'. Actually, I'm not doing anything. I don't believe I have sufficient access to run sftp, I only have a limited shell account, and no explicit permission to try running other services. The issue of sftp deamon configuration was just me wondering why the host provider hadn't bothered; it's not something I've even tried, nor does it directly have anything to do with Filezilla+SCP.

I am disappointed that you obviously have no interest in providing SCP support. As I've already acknowledged, I know that SCP lacks directory listing capabilities, but this is not an insurmountable issue as there are the standard shell commands available to get the listing information (ls), with a little effort to parse the reply data. Few protocols are used purely in isolation with no other supporting components. WinSCP quite obviously manages to do this, it just has an unpleasant UI, and is an application I'd rather not have to install.

Thank you for your replies in any case, at least I know that this is never going to happen.
Best Regards
Mac

comment:12 Changed 9 years ago by Tim Kosse

there are
the standard shell commands available to get the listing information (ls),
with a little effort to parse the reply data.

Unfortunately no, not that easy. It's extremely difficult to parse ls output, which for example is localized on non-English systems. Also, through startup scripts, environment variables and so on a lot of things can be set on an interactive shell that makes it impossible to parse.

comment:13 Changed 9 years ago by macrostb

I don't doubt there are difficulties with parsing responses from a shell login, however very little that's worth doing is usually all that easy ;). WinSCP somehow works around the limitations of the SCP protocol to provide an automatic directory list within a GUI interface. I don't know whether this is done by parsing the output of some shell commands (the only obvious solution I can think of). WinSCP itself is a sourceforge project, so I suppose I could take a look at the source ;) I see now that there is also a fork called WinSCP++ which adds sftp. I'd be tempted to switch, except that I still much prefer the FileZilla GUI.
Something I'll watch, and maybe investigate further when time permits.
Mac

comment:14 Changed 9 years ago by Jim Michaels

I know after watching a lot of IPTV on fancast or after doing a lot of uploads my router and/or modem must be power cycled because they lock up, usually the router. (WiMax, Linksys WRT54GS w up-to-date fw)
I just had to reset my router now. used to be every few days. router is getting old I guess, and not sure if I can afford to get an Apple router $$$.

Note: See TracTickets for help on using tickets.