Opened 11 years ago

Last modified 2 years ago

#4122 reopened Bug report

mainframe file directory omits tape (EBCDIC) files from display

Reported by: Dan Kowal Owned by:
Priority: low Component: FileZilla Client
Keywords: EBCDIC binary tape Cc: toconnell@…, dkowal@…
Component version: Operating system type: Windows
Operating system version: 5.00.2195 Service Pack 4

Description

FileZilla version is 3.1.6, build date 12/2/08

After logging in to a VM system and displaying a file directory, the detail list of files in the remote system's directory is incomplete.

It appears that the names of native files (EBCDIC) don't display. Names of ASCII text files do display.

No filters are in use (none are set up).

We know that this is a FileZilla problem, not a permissions or other issue, because we can view all of the files using a commercial product called WS_FTP which is similar to FileZilla. Our intent is to use FileZilla to perform binary downloads of data files from the mainframe to our network.

The FTP connection is accomplished through a Cisco VPN. ZoneAlarm firewall is running on our client Windows 2000 PC (ZoneAlarm is required by the host).

Attachments (2)

dkowal_FZ_log.txt (84.0 KB) - added by Dan Kowal 11 years ago.
dkowal_FZ_log2.txt (3.0 KB) - added by Dan Kowal 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

Enable "Show raw directory listing" in the settings dialog and post a complete log.

Changed 11 years ago by Dan Kowal

Attachment: dkowal_FZ_log.txt added

Changed 11 years ago by Dan Kowal

Attachment: dkowal_FZ_log2.txt added

comment:2 Changed 11 years ago by Dan Kowal

Keywords: tape added
Status: moreinfonew
Summary: mainframe file directory omits EBCDIC files from displaymainframe file directory omits tape (EBCDIC) files from display

Two log files attached, dkowal_FZ_log.txt and dkowal_FZ_log2.txt. First is complete log with target directory 'PSA.', second is easier to see, more specific target 'PSA.C4420.'.

It appears to show that directory entries of tape files on the MVS system don't display in the remote site directory, and are therefore unavailable for ftp download. Example from log:
18:56:27 Listing: V09899 Tape AIMAST.GDG.G0095V00

comment:3 Changed 11 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Will be fixed in the next version.

comment:4 Changed 5 years ago by gf.carpini

Priority: normalhigh
Resolution: fixed
Status: closedreopened

I see that in client 3.7.3 the problem is still there : tape files (a.k.a. archived files) are not listed for the mainframe directory, only the files on the on-line disks.

comment:5 Changed 5 years ago by Tim Kosse

Priority: highlow

Changed to low priority, there are very few users using such legacy systems.

comment:6 Changed 2 years ago by Kurt McKee

Cc: toconnell@paritysys.net; dkowal@paritysys.nettoconnell@paritysys.net, dkowal@paritysys.net

Triage suggestion

It appears there has been no movement on this ticket in 3 years.

I suggest closing the ticket.

@gf.carpini, if this is still an issue with FileZilla Client 3.26.1, would you please open a new ticket and post the complete log information and reference this ticket using the text #4122? Then the tickets will be linked.

Thanks!

Note: See TracTickets for help on using tickets.